首页 新闻 搜索 专区 学院

eclipse 安装 IBM MQ 插件 异常

0
[已解决问题] 解决于 2017-12-18 17:17

1.eclipse版本: 4.7.1.20171005-1200
2.IBM MQ Explorer Version: 9.0.4.0

问题描述:安装的过程中没有报错,当打开MQ资源管理器-导航器的时候,出现异常:
org.eclipse.core.runtime.CoreException: Plug-in com.ibm.mq.explorer.ui was unable to load class com.ibm.mq.explorer.ui.internal.views.MQNavigatorView.
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:194)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:176)
at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905
... 116 more
Caused by: org.osgi.framework.BundleException: Exception in com.ibm.mq.explorer.ui.internal.base.UiPlugin.start() of bundle com.ibm.mq.explorer.ui.
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:792)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:721)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:936)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:319)
at org.eclipse.osgi.container.Module.doStart(Module.java:571)
at org.eclipse.osgi.container.Module.start(Module.java:439)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:454)
at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
... 126 more
Caused by: java.lang.NullPointerException
at java.lang.String.equalsIgnoreCase(Unknown Source)
at com.ibm.mq.explorer.ui.internal.base.WorkspaceDescriptor.getInstallationDetails(WorkspaceDescriptor.java:173)
at com.ibm.mq.explorer.ui.internal.base.WorkspaceDescriptor.<init>(WorkspaceDescriptor.java:111)
at com.ibm.mq.explorer.ui.internal.base.WorkspaceManager.getDescriptorFromDir(WorkspaceManager.java:759)
at com.ibm.mq.explorer.ui.internal.base.WorkspaceManager.findWorkspaces(WorkspaceManager.java:674)
at com.ibm.mq.explorer.ui.internal.base.WorkspaceManager.checkAndPeformMigration(WorkspaceManager.java:354)
at com.ibm.mq.explorer.ui.internal.base.UiPlugin.startup(UiPlugin.java:437)
at com.ibm.mq.explorer.ui.internal.base.UiPlugin.start(UiPlugin.java:1905)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:771)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:764)
... 133 more
-------------------------------哪位大神 告诉一下

spring_monkey的主页 spring_monkey | 菜鸟二级 | 园豆:210
提问于:2017-12-04 15:18
< >
分享
最佳答案
0

如果你本机安装了MQ 就可能出现此问题。

解决方案:

卸载MQ,重启启动eclipse,即可解决!

spring_monkey | 菜鸟二级 |园豆:210 | 2017-12-18 17:17
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册