首页 新闻 搜索 专区 学院

看了虫师的selenium2自动化测试实战,第一个脚本就遇到问题,各位大佬看看怎么回事啊

0
[已解决问题] 解决于 2018-01-05 17:05
本人编程小白一枚
代码按照书中敲的,使用的pycharm,selenium库的版本是3.8
from selenium import webdriver

driver= webdriver.Firefox()
driver.get("http://www.baidu.com")

driver.find_element_by_id('kw1').send_keys("Selenium")
driver.find_element_by_id('su').click()
driver.quit()

帮忙看一下怎么回事
小浪剑客的主页 小浪剑客 | 菜鸟二级 | 园豆:204
提问于:2017-12-28 17:50
< >
分享
最佳答案
0

你的电脑上安装Firefox了吗?

奖励园豆:5
dudu | 高人七级 |园豆:36406 | 2017-12-28 20:33

安装了啊

小浪剑客 | 园豆:204 (菜鸟二级) | 2017-12-29 08:32
dudu | 园豆:36406 (高人七级) | 2017-12-29 14:19

@dudu: 谢谢,按照这个搭建后还是有问题,后来发现原因根本不是这个,我原来的搭建也是没有问题的,根本原因好像是我的火狐浏览器版本太低,导致selenium3不支持,但是又不能使用最新的,也是不支持,很难受,最后找了一个中间的才ok。困扰了我好几天,找了无数帖子,最后却是这么个小小的原因。

小浪剑客 | 园豆:204 (菜鸟二级) | 2018-01-05 11:19
其他回答(3)
1

安装火狐,或者谷歌浏览器

DanBrown | 园豆:1513 (小虾三级) | 2017-12-29 08:25

安装了呀,火狐谷歌都有的

支持(0) 反对(0) 小浪剑客 | 园豆:204 (菜鸟二级) | 2017-12-29 08:33
0

火狐浏览器的驱动或者环境配置不正确

smallsunshine | 园豆:208 (菜鸟二级) | 2017-12-29 14:59
0

火狐浏览器的版本问题,需要确定和selenium的对应

小浪剑客 | 园豆:204 (菜鸟二级) | 2018-01-05 11:20
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册