首页新闻找找看学习计划

为什么现在用create-react-app创建的项目只能运行ie11以上?

0
[待解决问题]

为什么现在用create-react-app创建的项目只能运行ie11以上?IE10及以下都无法运行,提示缺少map跟set方法,有谁知道怎么解决么?

打静爵的主页 打静爵 | 菜鸟二级 | 园豆:204
提问于:2018-01-04 09:23
< >
分享
所有回答(2)
0

百度: react+ie10

西漠以西 | 园豆:1670 (小虾三级) | 2018-01-04 10:34

找到解决办法了,引入polyfill。百度不到的。刚又试了下vue脚手架的,发现初始项目都是无法在IE10及以下运行的,要自己引入polyfill

支持(0) 反对(0) 打静爵 | 园豆:204 (菜鸟二级) | 2018-01-04 11:17

@打静爵: 百度这两个关键词,第三条。

https://stackoverflow.com/questions/40281727/how-to-get-promises-to-work-in-ie10-with-react

就是说的这个事。

支持(0) 反对(0) 西漠以西 | 园豆:1670 (小虾三级) | 2018-01-04 11:23
0

而且引入时注意要在其他文件最前面引入

打静爵 | 园豆:204 (菜鸟二级) | 2018-01-04 11:21
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册