首页 新闻 搜索 专区 学院

pip安装问题

-1
[已关闭问题] 关闭于 2018-01-26 10:43

python 版本3.6.2

pip安装时出现如下错误

AttributeError: module 'string' has no attribute 'whitespace'

是什么原因呢

怎么解决呢

环境设置正常

暖风先生的主页 暖风先生 | 菜鸟二级 | 园豆:208
提问于:2018-01-18 13:12
< >
分享
所有回答(3)
1

具体是在安装哪个包的时候出现这个错误的?

dudu | 园豆:37126 (高人七级) | 2018-01-18 13:21

缺少一个template的包

 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 14:35

就是pip包

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 14:36

@暖风先生: 建议将运行安装命令时的完整信息贴一下

支持(0) 反对(0) dudu | 园豆:37126 (高人七级) | 2018-01-18 15:20

@dudu: 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 16:37

@dudu: 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 16:43

@暖风先生: 建议参考 windows下安装easy_install, pip 及whl文件安装方法 这篇博文中的方法进行安装

支持(0) 反对(0) dudu | 园豆:37126 (高人七级) | 2018-01-18 16:47

@dudu: 这个是什么原因呢

之前提示缺少template包

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 16:53

@暖风先生: 将 Scripts 文件夹添加到 PATH 环境变量中试试

支持(0) 反对(0) dudu | 园豆:37126 (高人七级) | 2018-01-18 17:03

@dudu

\AppData\Local\Programs\Python\Python36-32\Scripts\C:\Python36\Scripts;

这样添加的 也不行

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:04

@暖风先生: 添加命令行中的完整路径

支持(0) 反对(0) dudu | 园豆:37126 (高人七级) | 2018-01-18 17:05

@dudu: 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:19

@dudu: 我快要疯了!

 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:20

@dudu: 我快要疯了!

 

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:20

@暖风先生: 删除,找更好的参考文档重新安装试试

支持(0) 反对(0) dudu | 园豆:37126 (高人七级) | 2018-01-18 17:27

@dudu: 只能这样了 

我还是重装吧

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:28

@dudu: 感谢解惑

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-18 17:28

@dudu: py3 以及py2的新版本中已经内置了PIP了。所以这些信息是滞后了的。

支持(0) 反对(0) 墨镜带佬星 | 园豆:2121 (老鸟四级) | 2018-01-20 00:15
1

python 2.7.9 及3.4以后的版本中已经内置有PIP了。
所以不存在需要安装PIP的事了。
----------

升级PIP:
https://pip.pypa.io/en/latest/installing/#upgrading-pip


配置使用加速源:
pip 默认是使用官方源,可以自己配置成使用国内的源。这样速度更快更流畅。
如果使用豆瓣的PIP源 参考:http://www.cnblogs.com/gayhub/p/5449328.html


其次是有了pip,通常不需要去下载WHL文件来安装了,pip install 模块名就可以自动完成从源下载对应版本的WHL文件并自动安装了。


我python 3.5.2
pip install whatever
安装很顺利地就成功了。

墨镜带佬星 | 园豆:2121 (老鸟四级) | 2018-01-20 00:15

之前的python3.6.2可能丢包了

pip出错

最后还是重装了

支持(0) 反对(0) 暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-26 10:41
0

自己已经解决,感谢各位

暖风先生 | 园豆:208 (菜鸟二级) | 2018-01-26 10:43
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册