首页新闻找找看学习计划

node 安装成功 ;但npm报错,什么原因?感谢帮忙

0
[已解决问题] 解决于 2018-03-23 09:52

什么原因呢,node新手,感谢大神帮忙!!!

问题补充:

有人知道么

库巴的主页 库巴 | 菜鸟二级 | 园豆:239
提问于:2018-03-12 09:44
< >
分享
最佳答案
0

原先安装过node,版本不匹配的原因

库巴 | 菜鸟二级 |园豆:239 | 2018-03-23 09:51
其他回答(3)
0

检查版本的命令不是“express -V”吗

豆子ll | 园豆:364 (菜鸟二级) | 2018-03-12 09:49

不是这个吧

 

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:04

@库巴: 要不你看看这个: http://www.cnblogs.com/lcq529/p/8493710.html 

支持(0) 反对(0) 豆子ll | 园豆:364 (菜鸟二级) | 2018-03-12 10:10

@小鹿L: node 里边包含npm,express是个模块吧,用npm安装的,现在npm报错,还是要感谢你了!

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:14
0

试试

# npm install --registry http://registry.cnpmjs.org/
dudu | 园豆:40840 (高人七级) | 2018-03-12 09:55

还是一样的,感谢

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:03

@库巴: 参考这里

支持(0) 反对(0) dudu | 园豆:40840 (高人七级) | 2018-03-12 10:14

@dudu:  ̄□ ̄||;英语很烂,我看看吧

感谢

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:15

@dudu: 好像没有

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:25

@库巴: 这是警告,不是报错,你安装包试试

支持(0) 反对(0) dudu | 园豆:40840 (高人七级) | 2018-03-12 10:29

@dudu: 对后边项目没影响?我先安装cnpm试试

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:30

@dudu: 什么都不能安装,npm也不能升级,0.0

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 10:34

@库巴: 参考 这里 彻底删除npm,然后重新安装

支持(0) 反对(0) dudu | 园豆:40840 (高人七级) | 2018-03-12 13:24
0
npm config set registry "https://registry.npm.taobao.org"

试试这个吧,直接改为cnpm的地址,就无需再装cnpm

方木一 | 园豆:332 (菜鸟二级) | 2018-03-12 15:18

好,稍等,我试试醉了,还是不行

 

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 15:37

@库巴: 看提示是当前 npm 不支持 node.js 9.8版本。

我看官网的node.js 9.8版本包含的 npm 为 5.6。

重新安装 9.8 版本时勾选也安装 npm。

支持(0) 反对(0) 方木一 | 园豆:332 (菜鸟二级) | 2018-03-12 15:51

@方木一: ok,我再试试,感谢

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 15:54

@方木一: 感谢,我没卸载node,只是重新安装,修复了一下,可能就好了

,再次感谢,我试试,淘宝镜像能否安装

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 15:59

@方木一: 加qq吧,872180840,还是有点问题

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 16:32

@方木一: 在安装node 了,还是版本不匹配的原因,最新版本的node不行

支持(0) 反对(0) 库巴 | 园豆:239 (菜鸟二级) | 2018-03-12 16:59
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册