首页新闻找找看学习计划

建了一个maven项目,pom文件第一行报错,报错如下:

0
悬赏园豆:20 [待解决问题]

错误如下:

Multiple annotations found at this line:
- Failure to find org.apache.maven.plugins:maven-war-plugin:jar:3.1 in https://repo.maven.apache.org/maven2 was cached in the
local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced
- No plugin found for prefix 'war' in the current project and in the plugin groups [] available from the repositories [local (D:\maven
\apache-maven-3.5.3-bin\maven_jar), central (https://repo.maven.apache.org/maven2)]

是jdk或者其它什么版本问题吗?(我用的jdk1.8+tomcat8)

qz12534的主页 qz12534 | 初学一级 | 园豆:166
提问于:2018-06-04 22:46

希望各位大大能帮忙看看,

qz12534 1年前
< >
分享
所有回答(2)
0

maven依赖没有下载成功,

在maven仓库地址找到目录org.apache.maven.plugins下的maven-war-plugin:jar:3.1相关内容,删掉,

重新执行,项目右键-》Maven -》Update Project >  ... 最好把Force Update of Snapshots/Releases勾选掉

 

eclipse maven创建javaweb项目

 

不会摇头的风扇 | 园豆:420 (菜鸟二级) | 2018-06-05 08:19

试过了,没有效果,想问您一下:tomcat8对应什么版本的dynamic web module ?网上只有tomcat7及以前版本的,,【感谢您的回答】

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-05 22:52
0
ycyzharry | 园豆:18370 (专家六级) | 2018-06-05 08:59

试过了,没有效果,想问您一下:tomcat8对应什么版本的dynamic web module ?网上只有tomcat7及以前版本的,,【感谢您的回答】

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-05 22:51

@qz12534: eclipse里面目前最高的选项也就是3.1了 但是3.0应该也能用的 可以看这篇帖子

解决“Dynamic Web Module 3.0 requires Java 1.6 or newer.”而不影响tomcat 8.0

支持(0) 反对(0) ycyzharry | 园豆:18370 (专家六级) | 2018-06-06 09:28

@ycyzharry: 感谢您的回复,网上几乎所有的方法我都试过,包括您的的这篇修改maven默认jdk版本的方法,结果还是不管用,我把我现在的报错发您看一下吧,

这是problem里报的错:

我按网上的解决方法都试过,比如下图:

等各项设置都配好了,但依然报cannot change version...那个错(真的很奇怪)

我的jdk1.8+tomcat8,我现在怀疑的是我的这个版本不能使用dynamic web module 3.1,不知道是否是这样?因为我真的试了几乎网上所有相关的解决方法,可能还有什么遗漏的吧,

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-06 10:46
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册