首页新闻找找看学习计划

tomcat8对应什么版本的dynamic web module ?网上只有tomcat7及以前版本的

0
悬赏园豆:10 [待解决问题]

tomcat8对应什么版本的dynamic web module ?网上只有tomcat7及以前版本的,,

问题补充:

网上tomcat7对应的是dynamic web module 3.0,我想问tomcat8是和什么版本dynamic web module配对,可以和低版本的dynamic web module配对吗?谢谢,

qz12534的主页 qz12534 | 初学一级 | 园豆:166
提问于:2018-06-05 22:53
< >
分享
所有回答(2)
0

Apache Tomcat version 8.0 implements the Servlet 3.1 and JavaServer Pages 2.3
Apache Tomcat version 8.5 implements the Servlet 3.1 and JavaServer Pages 2.3
Apache Tomcat version 9.0 implements the Servlet 4.0 and JavaServer Pages 2.3

、熙和 | 园豆:1486 (小虾三级) | 2018-06-06 09:12

我问的是和dynamic web module对应的版本,您知道吗?【感谢回答】

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-06 10:10

@qz12534: dynamic web module对应的是servlet的版本
java web开发离不开servlet, 所以 你还有什么不懂的

支持(0) 反对(0) 、熙和 | 园豆:1486 (小虾三级) | 2018-06-06 12:21

@、熙和: 也就是说,servlet的版本就是dynamic web module的版本吗?

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-06 14:00

@qz12534: 这里的指的是servlet的版本
我记得你配置之后,它生成的配置文件,里面写的就是对应的jst.web
没记错dynamic web module应该是eclipse里面的东西吧.
不用太纠结IDE里面这些,实际上配置这个就省去了你手动添加一些配置,它会给你生成出来一些文件

支持(0) 反对(0) 、熙和 | 园豆:1486 (小虾三级) | 2018-06-06 15:11

@、熙和: 您可以看一下我提的另外一个项目报错的问题,网上解决方法都试过了,结果还是报错,所以我怀疑我的jdk1.8+tomcat8和Dynamic Web Module 3.1.0 不搭配导致如下所示的错误,所以我才问版本搭配问题。

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-06 18:24

@qz12534: 建议你脱离ide , 在window的控制台cmd里面用maven跑一边,然后如果报错把错误信息贴全点,需要排除一下原因

支持(0) 反对(0) 、熙和 | 园豆:1486 (小虾三级) | 2018-06-06 20:34

@、熙和: 好的,谢谢,我试一下

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-07 09:13
0

参考:Java servlet

ycyzharry | 园豆:18405 (专家六级) | 2018-06-06 10:08

这张表我也看过,并没有从里面找到答案,,,是我看漏了吗?

支持(0) 反对(0) qz12534 | 园豆:166 (初学一级) | 2018-06-06 10:36
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册