首页新闻找找看学习计划

.net core 发布报错错误 NU1605: 检测到包降级

0
悬赏园豆:10 [已解决问题] 解决于 2018-06-08 17:03

错误 NU1605: 检测到包降级: System.Runtime.InteropServices 从 4.3.0 降级到 4.1.0。直接从项目引用包以选择不同版本。

 

下午打开nuget提示有更新,更新之后发现和log4net是否发生了兼容性冲突,但是我把log4net的包卸载,和引用清理之后发现依然是这个异常。

搞了一下午了,是在不晓得怎么处理。我觉得不是core垃圾应该是没找到正确的处理方式。

问题补充:

问题已解决,感谢1楼,下附解决方案


https://www.cnblogs.com/dudu/p/9096803.html

TylorChen的主页 TylorChen | 初学一级 | 园豆:104
提问于:2018-06-08 16:31
< >
分享
最佳答案
0
收获园豆:10
dudu | 高人七级 |园豆:41262 | 2018-06-08 16:47

依照错误提示“直接从项目引用包”做就可以解决

dudu | 园豆:41262 (高人七级) | 2018-06-08 16:48

谢谢,看了你的博客后解决了。

TylorChen | 园豆:104 (初学一级) | 2018-06-08 16:58
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册