首页新闻找找看学习计划

关于node.js的问题

0
[已解决问题] 解决于 2018-10-15 17:17

我是C++的一个学生,老师给了一个web项目给我们练手,说是要安装node.js才能运行,node.js安装好了,但是还是不能够运行这个网页,请问一下,node.js要怎么使用呢?

FFFFFFFly的主页 FFFFFFFly | 初学一级 | 园豆:108
提问于:2018-10-07 13:36
< >
分享
最佳答案
0

弄了很久终于发现,这是个vue项目,要在node.js中安装插件才能运行。 具体参考https://segmentfault.com/a/1190000009871504

FFFFFFFly | 初学一级 |园豆:108 | 2018-10-12 09:45
其他回答(1)
0

参考园子里的博文 Node.js 教程 02 - 经典的Hello World

dudu | 园豆:41262 (高人七级) | 2018-10-07 14:09

我用node命令打开,说找不到文件

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:11

@FFFFFFFly: 重新打开一个命令行窗口试试

支持(0) 反对(0) dudu | 园豆:41262 (高人七级) | 2018-10-07 14:15

@dudu: 我看网上面的资料说好像要先把项目导入node.js里面去,不太懂

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:16

@FFFFFFFly: node -v能正常运行吗?

支持(0) 反对(0) dudu | 园豆:41262 (高人七级) | 2018-10-07 14:21

@dudu: 显示8.12.0

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:21

@dudu: 打开了,但是报错了。。。。
SyntaxError: Unexpected token <
at createScript (vm.js:80:10)
at Object.runInThisContext (vm.js:139:10)
at Module._compile (module.js:617:28)
at Object.Module._extensions..js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
at Function.Module.runMain (module.js:694:10)
at startup (bootstrap_node.js:204:16)
at bootstrap_node.js:625:3

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:26

@dudu: 但是我看公司里面的维护人员就打开了,还是用的127.0.01,我连直接打开都打开不了。。。。这个是我们老师自己公司的一个项目,我们去旁听用这个项目练手。。。

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:28

@FFFFFFFly: 有没有在项目文件夹下运行npm install

支持(0) 反对(0) dudu | 园豆:41262 (高人七级) | 2018-10-07 14:30

@dudu: 能够说一下具体的流程吗?是用HBuilder这些编个函数运行?

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:33

@dudu: 血崩,刚才在项目文件夹安装npm也报错

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:41

@FFFFFFFly: 自己多试试,根据错误信息搜索相关参考资料

支持(0) 反对(0) dudu | 园豆:41262 (高人七级) | 2018-10-07 14:43

@dudu: 可以,我先问下为什么一定要用node.js呢?我只是在本地运行JS代码啊,这个原理到底是什么呢

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 14:44

@FFFFFFFly: 如果不用nodejs,你只能在浏览器中运行js

支持(0) 反对(0) dudu | 园豆:41262 (高人七级) | 2018-10-07 15:00

@dudu: 但是我浏览器也带不开这个网页。。。。。

支持(0) 反对(0) FFFFFFFly | 园豆:108 (初学一级) | 2018-10-07 15:01
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册