首页 新闻 搜索 专区 学院

linux安装weblogic无法进入控制台安装界面

0
悬赏园豆:20 [已解决问题] 解决于 2018-11-08 16:37

猫客123的主页 猫客123 | 初学一级 | 园豆:186
提问于:2018-11-08 09:11
< >
分享
最佳答案
0

系统信息

阿里云ECS(公共镜像)
Linux_CentOs_x64_6.8

原因

可能是因为新版本weblogic无法进入控制台安装了,远程ssh登录,系统未安装图形界面。

下面是我的操作步骤,供大家参考:

更新yum命令

yum update

配置/etc/profile环境变量

export JAVA_HOME=/usr/share/jdk1.8.0_191
export PATH=$JAVA_HOME/bin:$PATH
export CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar

添加weblogic用户并设置密码

adduser weblogic
passwd weblogic

增加交换空间

dd if=/dev/zero of=swapfile bs=1024 count=1024000
mkswap swapfile
swapon swapfile

安装xorg-x11-xauth xterm.x86_64 libXtst.x86_64

yum -y install xorg-x11-xauth
yum -y install xterm.x86_64
yum -y install libXtst.x86_64

通过Xmanager下面的Xstart执行命令 /usr/bin/xterm -ls -display $DISPLAY(weblogic用户)


最后Xstart启动后会有一个命令窗口,再执行weblogic安装程序,就可以成功弹出weblogic安装页面了

java -jar fmw_12.2.1.3.0_wls.jar

总结

因为我的linux没有安装图形界面,只能通过x11转发到本机上显示

猫客123 | 初学一级 |园豆:186 | 2018-11-08 16:34
其他回答(1)
0

试试安装一下 libxtst6

$ sudo apt-get update
$ sudo apt-get install libxtst6
收获园豆:20
dudu | 园豆:37569 (高人七级) | 2018-11-08 09:17

我是centOs更新了yum命令并安装了libXtst,现在错误还是找不到显示器输出源

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 09:35

@akoall: 如果 yum install libXtst 后还有问题,试试 yum install libXtst.i686

支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 09:39

@dudu: 还是不可以

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 09:42

@akoall: 看看电脑上有没有 libXtst.so 相关的文件

ls /usr/lib/x86_64-linux-gnu/libXtst.so*
支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 09:45

@dudu: 没有x86_64-linux-gnu这个文件夹

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 09:49

@akoall: 用 find 命令找一下

find /usr -name "libXtst.so*"
支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 09:55

@dudu:
[root@SolomenOne weblogic]# find /usr -name "libXtst.so*"
/usr/lib/libXtst.so.6.1.0
/usr/lib/libXtst.so.6
/usr/lib64/libXtst.so.6.1.0
/usr/lib64/libXtst.so.6

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 09:56

@akoall: 在 /usr/lib64/ 目录中创建软链接

ln -s libXtst.so.6 libXtst.so
支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 10:01

@dudu: 还是失败No X11 DISPLAY variable was set, but this program performed an operation which requires it.

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 10:08

@akoall: 试试 export DISPLAY=:0.0

支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 10:48

@dudu: 试过这个,也会出错Exception in thread "main" java.awt.AWTError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 11:05
支持(0) 反对(0) dudu | 园豆:37569 (高人七级) | 2018-11-08 11:12

@dudu: 解决了,谢谢你

支持(0) 反对(0) 猫客123 | 园豆:186 (初学一级) | 2018-11-08 16:35
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册