首页 新闻 搜索 专区 学院

Linux7.5 安装gcc 依赖库低于当前系统库版本如何解决?

0
悬赏园豆:5 [已解决问题] 解决于 2018-11-22 17:06

Error: Protected multilib versions: nss-softokn-freebl-3.34.0-2.el7.i686 != nss-softokn-freebl-3.36.0-5.el7_5.x86_64

系统已安装 nss-softokn-freebl-3.36.0-5.el7_5.x86_64
gcc 依赖 nss-softokn-freebl-3.34.0-2.el7.i686

如何解决这个错误?

枫夜雪的主页 枫夜雪 | 初学一级 | 园豆:196
提问于:2018-11-14 18:00
< >
分享
最佳答案
0

第一次使用的yum源是我从网易开源镜像下载进行了修改,导致yum源不完整,没有更新,我又重新重新下载了一份新的未做修改,yum update 后 可以正常安装了

枫夜雪 | 初学一级 |园豆:196 | 2018-11-22 17:05
其他回答(2)
0

运行 yum update 看能否解决这个问题

收获园豆:5
dudu | 园豆:38276 (高人七级) | 2018-11-14 18:12

试过了,没有更新信息,现在是gcc 未安装,依赖已经是最新版本了

支持(0) 反对(0) 枫夜雪 | 园豆:196 (初学一级) | 2018-11-14 18:15

@枫夜雪: 你是怎么安装 gcc 的?

支持(0) 反对(0) dudu | 园豆:38276 (高人七级) | 2018-11-14 18:17

@枫夜雪: nss-softokn-freebl-3.34.0-2.el7.i686 是 32 位的,nss-softokn-freebl-3.36.0-5.el7_5.x86_64 是 64 位的

支持(0) 反对(0) dudu | 园豆:38276 (高人七级) | 2018-11-14 18:19

@枫夜雪: 你好像是在 64 位的 centos 上安装 32 位的 gcc

支持(0) 反对(0) dudu | 园豆:38276 (高人七级) | 2018-11-14 18:20

@dudu: 我的yum源是64位的啊,这个问题怎么解决呢?

支持(0) 反对(0) 枫夜雪 | 园豆:196 (初学一级) | 2018-11-15 12:04
0

更新yum

Harmony-MrWang | 园豆:204 (菜鸟二级) | 2018-11-16 00:20

yum update 提示已经是最新的了

支持(0) 反对(0) 枫夜雪 | 园豆:196 (初学一级) | 2018-11-16 14:46
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册