首页新闻找找看学习计划

c#程序运行时报错”未在本地计算机上注册“OraOLEDB.Oracle”提供程序。

0
悬赏园豆:15 [待解决问题]

已经安装了ODAC的组件,仍然报错未在本地计算机上注册“OraOLEDB.Oracle”提供程序

小太阳与码农的主页 小太阳与码农 | 初学一级 | 园豆:176
提问于:2018-11-20 15:44
< >
分享
所有回答(6)
0

你需要重启

顽皮大叔 | 园豆:314 (菜鸟二级) | 2018-11-20 15:47
0

改一下目标平台试试,改成 X86 或者 X64

jqw2009 | 园豆:1891 (小虾三级) | 2018-11-20 15:48

试过了,没有用,依然报错

支持(0) 反对(0) 小太阳与码农 | 园豆:176 (初学一级) | 2018-11-20 15:55

@小太阳与码农: 直接用 Oracle.ManagedDataAccess.dll 这个dll直接调用oracle数据

支持(0) 反对(0) jqw2009 | 园豆:1891 (小虾三级) | 2018-11-20 15:58
0

用register 命令试试

会长 | 园豆:5259 (大侠五级) | 2018-11-20 15:55

这个要怎么用

支持(0) 反对(0) 小太阳与码农 | 园豆:176 (初学一级) | 2018-11-20 15:56

@小太阳与码农: 操作系统的一个命令,试试看

支持(0) 反对(0) 会长 | 园豆:5259 (大侠五级) | 2018-11-20 16:08
0

直接重装一下oracle客户端。

花飘水流兮 | 园豆:10177 (专家六级) | 2018-11-20 16:15

这样做的目的是?

支持(0) 反对(0) 小太阳与码农 | 园豆:176 (初学一级) | 2018-11-20 16:50
0

oracle版本?11?12?

rqx | 园豆:468 (菜鸟二级) | 2018-11-20 18:55

11g

支持(0) 反对(0) 小太阳与码农 | 园豆:176 (初学一级) | 2018-11-21 08:28

@小太阳与码农: 安装ODAC是,选项需要勾选 Oracle Provider for OLEDB,X64的话,可以试试64与32的版本都装一下

支持(0) 反对(0) rqx | 园豆:468 (菜鸟二级) | 2018-11-21 10:03
0

oracle这玩意,我一般都用x86,不然都不知道怎么报的错

魔多 | 园豆:1014 (小虾三级) | 2018-11-24 13:01
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册