首页新闻找找看学习计划

angular脚手架在ie9+下兼容问题

0
悬赏园豆:10 [待解决问题]

ie11下报错:ERROR TypeError: 对象不支持“includes”属性或方法
...我不知道这是什么错。

在网上搜了一下ie兼容angular问题 都是说要安装上面两处依赖,我按照步骤走了,还是这个样子

HJumping的主页 HJumping | 初学一级 | 园豆:33
提问于:2019-02-13 16:18
< >
分享
所有回答(1)
0

找一下你的项目中,哪儿用到了includes方法,这个需要安装额 es6-polyfills

幻天芒 | 园豆:36522 (高人七级) | 2019-02-13 17:10

就一处用到了我把includes换成了 别的方法 他还是报这样的错(╯‵□′)╯︵┻━┻

就这一处用到了,我去安装es6-polyfills试一下再

支持(0) 反对(0) HJumping | 园豆:33 (初学一级) | 2019-02-13 17:32

安装也不行

支持(0) 反对(0) HJumping | 园豆:33 (初学一级) | 2019-02-13 18:24

@HJumping: 你把打包后的JS拿来全文搜索,哪儿有includes吧。找到这个点再说。另外,你可以给数组扩充一个includes方法。

支持(0) 反对(0) 幻天芒 | 园豆:36522 (高人七级) | 2019-02-14 14:56

@幻天芒: mdn上说 includes不兼容ie 那就还是我项目里边的文件包含这个方法,我一直在找,但是好难找啊

支持(0) 反对(0) HJumping | 园豆:33 (初学一级) | 2019-02-15 10:29

@HJumping: 打包后就那个几个js,扔到VSC,搜索一下就找到了。 另外就是打补丁,自己写一个includes方法,挂在数组原型上。

支持(0) 反对(0) 幻天芒 | 园豆:36522 (高人七级) | 2019-02-15 10:48

@幻天芒: 太惭愧了

支持(0) 反对(0) HJumping | 园豆:33 (初学一级) | 2019-02-18 09:09
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册