首页新闻找找看学习计划

centos 7 升级 docker engine 问题

0
悬赏园豆:30 [已解决问题] 解决于 2019-03-31 14:52

从 docker-ce 18.03.1 升级至 18.09.4 ,在安装 docker-ce-cli 时

# rpm -Uvh docker-ce-cli-18.09.4-3.el7.x86_64.rpm

出现下面的错误:

file /usr/bin/docker from install of docker-ce-cli-1:18.09.4-3.el7.x86_64 conflicts with file from package docker-ce-18.03.1.ce-1.el7.centos.x86_64
    file /usr/share/bash-completion/completions/docker from install of docker-ce-cli-1:18.09.4-3.el7.x86_64 conflicts with file from package docker-ce-18.03.1.ce-1.el7.centos.x86_64
...

请问如何解决?

dudu的主页 dudu | 高人七级 | 园豆:40749
提问于:2019-03-31 14:43
< >
分享
最佳答案
0

需要先卸载已经安装的 docker engine

# yum remove docker-ce
dudu | 高人七级 |园豆:40749 | 2019-03-31 14:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册