首页新闻找找看学习计划

最近做react项目剪切用户头像上传时安装react-cropper插件时出现以下依赖错误,请大佬解答,不知道怎么解决

0
悬赏园豆:20 [已关闭问题] 关闭于 2019-08-12 16:20

gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack at ChildProcess.emit (events.js:196:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:257:12)
gyp ERR! System Darwin 18.5.0
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64/fse.node" "--module_name=fse" "--module_path=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64"
gyp ERR! cwd /Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents
gyp ERR! node -v v12.2.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64/fse.node --module_name=fse --module_path=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64' (1)
node-pre-gyp ERR! stack at ChildProcess.<anonymous> (/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:196:13)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:1011:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:268:5)
node-pre-gyp ERR! System Darwin 18.5.0
node-pre-gyp ERR! command "/usr/local/bin/node" "/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents
node-pre-gyp ERR! node -v v12.2.0
node-pre-gyp ERR! node-pre-gyp -v v0.6.29
node-pre-gyp ERR! not ok
Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64/fse.node --module_name=fse --module_path=/Users/mike/Desktop/donghang/node_modules/react-scripts/node_modules/fsevents/lib/binding/Release/node-v72-darwin-x64' (1)
npm WARN @ant-design/icons-react@1.1.5 requires a peer of react@16.x but none is installed. You must install peer dependencies yourself.
npm WARN antd@3.17.0 requires a peer of react@>=16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN antd@3.17.0 requires a peer of react-dom@>=16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@0.3.0 requires a peer of babel-eslint@7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@0.3.0 requires a peer of eslint@3.8.1 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@0.3.0 requires a peer of eslint-plugin-flowtype@2.21.0 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@0.3.0 requires a peer of eslint-plugin-import@2.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@0.3.0 requires a peer of eslint-plugin-react@6.4.1 but none is installed. You must install peer dependencies yourself.
npm WARN html-to-react@1.3.4 requires a peer of react@^16.0 but none is installed. You must install peer dependencies yourself.
npm WARN rc-switch@1.9.0 requires a peer of react@^16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN rc-switch@1.9.0 requires a peer of react-dom@^16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN babel-core@7.0.0-bridge.0 requires a peer of @babel/core@^7.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN The package react-ace is included as both a dev and production dependency.
npm WARN The package react-addons-css-transition-group is included as both a dev and production dependency.
npm WARN The package react-addons-transition-group is included as both a dev and production dependency.
npm WARN The package react-dom is included as both a dev and production dependency.
npm WARN The package react-draggable-tags is included as both a dev and production dependency.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/react-scripts/node_modules/fsevents):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 install: node-pre-gyp install --fallback-to-build
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

  • react-cropper@1.2.0
    updated 1 package and audited 22266 packages in 98.006s
    found 459 vulnerabilities (185 low, 218 moderate, 53 high, 3 critical)
    run npm audit fix to fix them, or npm audit for details
清宵的主页 清宵 | 初学一级 | 园豆:90
提问于:2019-05-15 17:36
< >
分享
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册