首页新闻找找看学习计划

spring boot 新建项目 pom文件 未知错误

0
悬赏园豆:15 [已解决问题] 解决于 2019-06-05 16:51
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>2.1.5.RELEASE</version>
        <relativePath/> <!-- lookup parent from repository -->
    </parent>
    <groupId>com.example</groupId>
    <artifactId>AjaxTest</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <name>AjaxTest</name>
    <description>Demo project for Spring Boot</description>

    <properties>
        <java.version>1.8</java.version>
    </properties>

    <dependencies>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>

        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-test</artifactId>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-devtools</artifactId>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-maven-plugin</artifactId>
            </plugin>
        </plugins>
    </build>

</project>


新建项目的时候第一行一直报错,找不到原因,但是不影响正常运行。
如果是新建成war包则没有,jar包就一直报错。
鼠标放在上面也没有提示 哭了

随意的马蒂洛克的主页 随意的马蒂洛克 | 初学一级 | 园豆:114
提问于:2019-05-25 11:24
< >
分享
最佳答案
0

我教你一个办法,叫二分法,先把pom删的只剩第一行,看报不报错,如果不报,增加原文件一半内容,看报不报错,注意xml标签要完整,如果报错,错就在这一半里,然后把这一半再删除一半的内容,看报不报错,如果不报,那么错就在剩余的四分之一里,以此类推,就这样一点点确定错误的位置,这是没有办法的办法,你可以试试

收获园豆:8
流年飞雨 | 小虾三级 |园豆:1923 | 2019-05-26 14:45

不管分几次第一行都是显示错误.... 我已经放弃了

随意的马蒂洛克 | 园豆:114 (初学一级) | 2019-05-27 09:08

@随意的马蒂洛克: 只留第一行还有错吗?不太可能吧,这样的话删了重建个文件

流年飞雨 | 园豆:1923 (小虾三级) | 2019-05-28 21:59

@流年飞雨: 我已经放弃了 删了重新建还是这个样子

随意的马蒂洛克 | 园豆:114 (初学一级) | 2019-05-29 11:29
其他回答(3)
0

这个是我项目的配置,你可以试一下

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns="http://maven.apache.org/POM/4.0.0"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

收获园豆:7
狼爷 | 园豆:1192 (小虾三级) | 2019-05-27 01:23

也不行 我也不知道哪里出错了 不影响正常运行 就是看着这个报错不舒服

支持(0) 反对(0) 随意的马蒂洛克 | 园豆:114 (初学一级) | 2019-05-27 09:00
0

你好,我也有这个问题,请问你知道原因了吗

惆怅于取名的程序猿 | 园豆:202 (菜鸟二级) | 2019-05-28 17:13

不知道.. 虽然不影响正常运行 就是看着不舒服

支持(0) 反对(0) 随意的马蒂洛克 | 园豆:114 (初学一级) | 2019-05-29 11:26
0

我也是遇到过这个问题,后边百度找到了一个答案,说是因为升级到2.1.5之后,maven的版本是3.1.2,可能有些插件不支持导致的,添加版本信息就没问题:
<properties>
<java.version>1.8</java.version>
<maven-jar-plugin.version>3.1.1</maven-jar-plugin.version>
</properties>

nickname | 园豆:202 (菜鸟二级) | 2019-06-07 17:49
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册