首页新闻找找看学习计划

VS2008sp1打开没问题,但是迁移到VS2019却一直编译失败

0
悬赏园豆:50 [待解决问题]

有个DLL可以引用,但是只要调用引用DLL就会报错。
奇怪的是VS2008sp1是没有问题的,我电脑就一个VS2019。我检查了都是用的 .net framework 2.0,版本都一致。

问题补充:

截图看的不是很清楚,点击放大不了,暂时可以通过浏览器整个页面鼠标滚轮放大查看。

下面是vs08sp1编译是正常的

下图是vs19编译错误。我个人有尝试过生成.net3.5,就可以正常通过。

查看到的DLL版本

迁移报告:

问题很奇怪,不太清楚迁移过程中改变了什么。之前有用过10的迁移到17的都没有问题过。

MeDuke的主页 MeDuke | 初学一级 | 园豆:44
提问于:2019-05-27 17:21

具体报错信息是什么?

dudu 5个月前

@dudu: 其实错误信息我猜测vs19导致某些组件.net版本变高了,因为我把.net2.0改成3.5就可以正常编译了。但是我没找到哪里发生了变化,这个dll是公司内部的。

MeDuke 5个月前
< >
分享
所有回答(4)
0

截图看看,

学会乐观 | 园豆:653 (小虾三级) | 2019-05-27 17:54

截图放在补充问题了。麻烦看一下。谢谢了。

支持(0) 反对(0) MeDuke | 园豆:44 (初学一级) | 2019-05-28 10:01
0

我也遇到编译会报错,但是还是能够正常编译成功

猴子哥 | 园豆:632 (小虾三级) | 2019-05-27 21:34

我是无法生成的

支持(0) 反对(0) MeDuke | 园豆:44 (初学一级) | 2019-05-28 10:01
0

cd 进入 C:\Windows\Microsoft.NET\Framework 下面。挨个进v2.0.50727,v4.0.30319版本里面
命令 aspnet_regiis.exe -u 先卸载,然后aspnet_regiis.exe -i

试下重新注册下Framework

大志若愚 | 园豆:967 (小虾三级) | 2019-05-28 10:14
0

VS 不是建议你直接升级项目的 .net 框架吗,你先升级,成功之后再迁移就好了

三人乐乐 | 园豆:3180 (老鸟四级) | 2019-05-28 14:07

公司还是希望用2.0的。没办法,我重新安装了一个08 sp1.

支持(0) 反对(0) MeDuke | 园豆:44 (初学一级) | 2019-05-28 14:10
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册