首页新闻找找看学习计划

.netcore2.0实现了Standard 2.0,为什么基于Standard 2的类库却需要.netcore2.2才可以引用?

0
[待解决问题]

.netcore2.0实现了Standard 2.0,
为什么基于Standard 2的类库却需要.netcore2.2才可以引用?
在Standard 2.0,引用没问题,
但在.netcore2.1中就提示需要2.2的

he69的主页 he69 | 菜鸟二级 | 园豆:215
提问于:2019-07-11 10:48
< >
分享
所有回答(2)
0

问题不在 .net standard 2.0 ,建议提供更多信息,并提供完整的错误提示信息

dudu | 园豆:41305 (高人七级) | 2019-07-11 10:58

谢谢你的回复

Senparc.Weixin是Standard 2.0,我的项目是.netcore2.1,只是奇怪为什么.netcore2.1已经实现了Standard 2.0为什么却不能引用Standard 2.0的类库

以下是错误信息:
错误 NU1107 Microsoft.AspNetCore.Antiforgery 中检测到版本冲突。直接安装/引用 Microsoft.AspNetCore.Antiforgery 2.2.0 到项目 WXSend 可解决此问题。
WXSend -> Senparc.Weixin.WxOpen 3.4.9 -> Senparc.Weixin.MP 16.7.9 -> Senparc.NeuChar.App 0.5.4 -> Microsoft.AspNetCore.Mvc 2.2.0 -> Microsoft.AspNetCore.Mvc.ViewFeatures 2.2.0 -> Microsoft.AspNetCore.Antiforgery (>= 2.2.0)
WXSend -> Microsoft.AspNetCore.App 2.1.12 -> Microsoft.AspNetCore.Antiforgery (>= 2.1.1 && < 2.2.0). WXSend E:\Pro\WXSend\WXSend\WXSend.csproj

支持(0) 反对(0) he69 | 园豆:215 (菜鸟二级) | 2019-07-11 11:17
支持(0) 反对(0) dudu | 园豆:41305 (高人七级) | 2019-07-11 11:40

@dudu: 这个在出现问题的时候就查找到看了,但这个是真正的版本冲突;
我发这个已经不是版本冲突了,是.netcore目标框架不一致,目前我们服务器上框架为2.1,如果改2.2就运行不了了。
Microsoft.AspNetCore.Antiforgery,是.netcore中的类库,不能单独更新

支持(0) 反对(0) he69 | 园豆:215 (菜鸟二级) | 2019-07-11 11:44

@he69: 在服务器上安装支持 .net core 2.2 的 sdk

支持(0) 反对(0) dudu | 园豆:41305 (高人七级) | 2019-07-11 13:08

@dudu: ( ̄▽ ̄)" 能这样最好,但改不了。
实际主要是想问问大家,为什么:
“.netcore2.0实现了Standard 2.0,
为什么基于Standard 2的类库却需要.netcore2.2才可以引用?”
能弄清楚这个就好了

支持(0) 反对(0) he69 | 园豆:215 (菜鸟二级) | 2019-07-11 14:14

@he69: 从 WXSend -> Microsoft.AspNetCore.App 2.1.12 看,WXSend 依赖并不是 .net standard 2.0

支持(0) 反对(0) dudu | 园豆:41305 (高人七级) | 2019-07-11 14:38
0

这是包版本的问题和 netstandard 没关系

WeihanLi | 园豆:189 (初学一级) | 2019-08-07 13:49
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册