首页新闻找找看学习计划

vue项目在IE浏览器怎么打不开?

0
[待解决问题]

用vue任何和bootstrap做了一个网页,但是在IE浏览器下打开是空白的,请问怎么兼容?
本人已经安装了插件:cnpm i babel-polyfill --save
也引入了:import 'babel-polyfill'
。但是在浏览器报错:SCRIPT1006: 缺少 ')'
SCRIPT5009: “Promise”未定义

。请大神提点意见

前端便当的主页 前端便当 | 菜鸟二级 | 园豆:202
提问于:2019-09-03 15:48
< >
分享
所有回答(4)
0

是不是你代码中缺少) 这个一看就是你的代码的问题 你可以尝试页面中啥也不放 就一个单页面你看看能不能访问 这个我敢肯定是你代码的问题

Mr--WANG | 园豆:216 (菜鸟二级) | 2019-09-03 17:12

感谢,但是今天检查了一遍, 并没有缺少括号。。。。

支持(0) 反对(0) 前端便当 | 园豆:202 (菜鸟二级) | 2019-09-04 10:04
0

vue好像最低兼容到ie9 而且旧版本的ie是不支持Promise的,关于Promise的需要自己实现

wings-lhw | 园豆:340 (菜鸟二级) | 2019-09-03 17:54

是的,还报错说promise未定义,怎么整啊

支持(0) 反对(0) 前端便当 | 园豆:202 (菜鸟二级) | 2019-09-04 10:00

@前端便当: Promise 不支持在页面引入<script src="https://polyfill.io/v3/polyfill.min.js"></script>

或<script src="https://cdn.bootcss.com/babel-polyfill/7.2.5/polyfill.min.js"></script>,第2个js可以下载后在本地引入

支持(0) 反对(0) wings-lhw | 园豆:340 (菜鸟二级) | 2019-09-04 16:21
0

建议使用 webpack + babel plugin + corejs 等工具进行打包,当然,最简单的就是使用 vue-cli 来创建项目

不如隐茶去 | 园豆:526 (小虾三级) | 2019-09-03 23:18
0
张朋举 | 园豆:1627 (小虾三级) | 2019-09-07 19:42
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册