首页新闻找找看学习计划

.net core3.0集成swagger问题

0
悬赏园豆:5 [待解决问题]

用2.0使用swagger完全没问题,但是使用3.0就会报错,很奇葩的错。
“MissingMethodException: Method not found: 'Void Microsoft.AspNetCore.StaticFiles.StaticFileMiddleware..ctor(Microsoft.AspNetCore.Http.RequestDelegate, Microsoft.AspNetCore.Hosting.IHostingEnvironment, Microsoft.Extensions.Options.IOptions`1<Microsoft.AspNetCore.Builder.StaticFileOptions>, Microsoft.Extensions.Logging.ILoggerFactory)'.”
是不是因为3.0使用了新的路由规则

灬丶的主页 灬丶 | 初学一级 | 园豆:11
提问于:2019-09-16 16:31
< >
分享
所有回答(3)
0

在命令行中,创建一个3.0项目,对比一下Startup.cs 有什么不同,用新建的3.0的配置

秋壶冰月 | 园豆:5434 (大侠五级) | 2019-09-16 17:15

很多不一样

支持(0) 反对(0) 灬丶 | 园豆:11 (初学一级) | 2019-09-16 17:53

但是创建的好像不能用vs打开,只能用vs code

支持(0) 反对(0) 灬丶 | 园豆:11 (初学一级) | 2019-09-16 17:54

@灬丶: 那着重看错误信息,按你上面发的,应该是在StaticFileMiddleware(启用静态文件中间件)这一块,至于vs无法打开新建.Net Core 3.0项目,那应该是3.0 preview 9这个版本吧,这个版本需要用vs 2019 16.3(预览版)才支持,在.Net Core 3.0正式发布的时候,vs也会同步更新的

支持(0) 反对(0) 秋壶冰月 | 园豆:5434 (大侠五级) | 2019-09-16 17:58

推荐使用jetbrains的rider,个人感觉做c#开发完爆visual studio;更别提vscode了。

支持(0) 反对(0) 张朋举 | 园豆:1188 (小虾三级) | 2019-09-17 09:02
0

升级swagger,低版本在3.0上会出问题

雨雾星天 | 园豆:206 (菜鸟二级) | 2019-09-17 11:29

我的是最新的swagger

支持(0) 反对(0) 灬丶 | 园豆:11 (初学一级) | 2019-09-17 13:50
0
灵行寻燕 | 园豆:226 (菜鸟二级) | 2019-09-18 11:41
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册