首页新闻找找看学习计划

vue 3.0 如何 运行之前得 vue2.0 得项目

0
[待解决问题]

各位大佬,最近把vue 升级到 3.0 但是之前得 2.9.6 得项目没办法启动了,求问一下,怎么在不降版本得前提下,运行之前得项目。
(我搜了好多,都是如何在vue 3.0 基础上 创建2.0 得项目)

报这个错呢

E:\lc\jinan\resource-management>npm run dev

> resource-management@1.0.0 dev E:\lc\jinan\resource-management
> webpack-dev-server --host 192.168.1.179 --inline --progress --config build/webpack.dev.conf.js

 10% building modules 1/1 modules 0 activeevents.js:174
      throw er; // Unhandled 'error' event
      ^

Error: listen EADDRNOTAVAIL: address not available 192.168.1.179:8081
    at Server.setupListenHandle [as _listen2] (net.js:1262:19)
    at listenInCluster (net.js:1327:12)
    at doListen (net.js:1460:7)
    at process._tickCallback (internal/process/next_tick.js:63:19)
    at Function.Module.runMain (internal/modules/cjs/loader.js:834:11)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)
Emitted 'error' event at:
    at emitErrorNT (net.js:1306:8)
    at process._tickCallback (internal/process/next_tick.js:63:19)
    [... lines matching original stack trace ...]
    at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! resource-management@1.0.0 dev: `webpack-dev-server --host 192.168.1.179 --inline --progress --config build/webpack.dev.conf.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the resource-management@1.0.0 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\fengcy\AppData\Roaming\npm-cache\_logs\2019-11-11T08_51_46_088Z-debug.log
沁猿春的主页 沁猿春 | 菜鸟二级 | 园豆:202
提问于:2019-11-11 17:12
< >
分享
所有回答(4)
0

用的2x,没遇到过

web_兵兵 | 园豆:172 (初学一级) | 2019-11-11 17:16

谢谢。已经解决了

支持(0) 反对(0) 沁猿春 | 园豆:202 (菜鸟二级) | 2019-11-12 15:33
0

2019-11-11T08_51_46_088Z-debug.log 贴一下这个日志里面的错误信息输出,我看一下。刚刚我把我本地vue 2.9的删了,升级了之后是vue4.0,运行以前的项目是好的。你试试升级到4.0后看能不能运行。不过我还是怀疑可能和代码有关,你贴下日志,然后方便的话升级一下vue到4.0。
(npm uninstall vue-cli -g 卸载,npm install -g @vue/cli 升级)

默卿 | 园豆:4400 (老鸟四级) | 2019-11-11 17:57

谢谢, 代码得问题,需要把node-modules删了 然后重新下载依赖 已经解决了

支持(0) 反对(0) 沁猿春 | 园豆:202 (菜鸟二级) | 2019-11-12 15:33
0

vue3.0 似乎才完成核心代码吧?都没发布。。。

muamaker | 园豆:746 (小虾三级) | 2019-11-12 11:01

谢谢 我写错了 。。。
是 vue-cli 已经解决了

支持(0) 反对(0) 沁猿春 | 园豆:202 (菜鸟二级) | 2019-11-12 15:32
0

vue3还没发布啊,api之类的还没兼容完啊?你是怎么敢直接用vue3的

wings-lhw | 园豆:346 (菜鸟二级) | 2019-11-12 15:26

谢谢 我写错了 。。。
是 vue-cli 已经解决了

支持(0) 反对(0) 沁猿春 | 园豆:202 (菜鸟二级) | 2019-11-12 15:32
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册