首页 新闻 搜索 专区 学院

linux 下运行selenium报错?

0
悬赏园豆:10 [已解决问题] 解决于 2020-11-07 12:30


我使用了最新的Firefox和geckodriver,但是一直说版本不匹配,就很奇怪,(此外我还测试了低版本的Firefox和geckodriver,有65==》0.20,但是都不行 ),系统版本,查了很多资料都不行,特此问问 是不是系统的原因?

周荀的主页 周荀 | 初学一级 | 园豆:147
提问于:2019-11-21 14:01
< >
分享
最佳答案
0

该问题产生的原因是selenium的浏览器驱动和浏览器版本对应不上。

收获园豆:10
ycyzharry | 高人七级 |园豆:22051 | 2019-11-21 23:26

你的意思是说geckodriver和Firefox版本不对应是吧,但是我用最新的Firefox和geckodriver版本也是这个报错,而且我试了好几个都不行 ,我在想是不是要降低到Firefox60以下,

周荀 | 园豆:147 (初学一级) | 2019-11-22 11:39

@周荀: 不用最新的火狐

ycyzharry | 园豆:22051 (高人七级) | 2019-11-22 15:53

@ycyzharry: 我用了65的然后用了对应的0.20的geckodriver但还是不行,所以我在想是不是系统centos6.5有问题,所以导致无法执行

周荀 | 园豆:147 (初学一级) | 2019-11-22 15:54

@周荀: 跟系统没关系 在网上找找能和驱动对应的版本

ycyzharry | 园豆:22051 (高人七级) | 2019-11-22 21:15
其他回答(1)
0

11111

周荀 | 园豆:147 (初学一级) | 2020-11-07 12:29
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册