首页 新闻 搜索 专区 学院

关于mac的django问题

0
[待解决问题]

macbookair升级到catalina后,python的版本一直默认2.7。修改~/.bashprofile以及~/.bashrc文件后会在终端默认为3.8版本,但是安装django时会提示
"This version of Django requires Python 3.6, but you're trying to install it on Python 2.7."
各位大佬求解啊

老董少年的主页 老董少年 | 菜鸟二级 | 园豆:202
提问于:2019-11-30 14:21
< >
分享
所有回答(1)
1

你是怎么安装 django 的?

dudu | 园豆:38820 (高人七级) | 2019-11-30 14:37

git clone url 来下载的 然后在终端到django目录下 sudo python setup.py install进行安装  但是到这步就出现问题中的提示了

支持(0) 反对(0) 老董少年 | 园豆:202 (菜鸟二级) | 2019-11-30 14:48

@老董少年: 试试下面的安装命令,参考 How to Set Default Version of Python to 3.x vs 2.7 on Mac OSX?

pip3 install django
python3 -m pip install django
支持(1) 反对(0) dudu | 园豆:38820 (高人七级) | 2019-11-30 15:07

@dudu: 感谢大佬啊!!!!

支持(0) 反对(0) 老董少年 | 园豆:202 (菜鸟二级) | 2019-11-30 15:24
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册