首页新闻找找看学习计划

standard 项目里如何引用 Microsoft.AspNetCore.Http 3.1

0
悬赏园豆:20 [已解决问题] 解决于 2020-01-09 23:03

standard 项目里如何引用 Microsoft.AspNetCore.Http 3.1,nuget包只有 2.2.2的版本

bendanwang的主页 bendanwang | 初学一级 | 园豆:152
提问于:2020-01-09 16:14
< >
分享
最佳答案
0

.csproj 中添加

<ItemGroup>
    <FrameworkReference Include="Microsoft.AspNetCore.App" />
</ItemGroup>
收获园豆:20
dudu | 高人七级 |园豆:38642 | 2020-01-09 18:06

编译不通过

bendanwang | 园豆:152 (初学一级) | 2020-01-09 18:16

@bendanwang: 试试 <Project Sdk="Microsoft.NET.Sdk.Web">

dudu | 园豆:38642 (高人七级) | 2020-01-09 18:22

@dudu: 还是编译不通过,一样的错误

bendanwang | 园豆:152 (初学一级) | 2020-01-09 18:51

@bendanwang: 那只能把 TargetFramework 改为 netcoreapp3.0

dudu | 园豆:38642 (高人七级) | 2020-01-09 18:53

@dudu: 现在需要在基础建设类库里添加一些帮助类,而帮助类里又有aspnet core 3.1的内容的。这个博客园是怎么解决的呢?

bendanwang | 园豆:152 (初学一级) | 2020-01-09 19:05

@bendanwang: 我们已经在逐步将 TargetFramework 改为 netcoreapp3.0

dudu | 园豆:38642 (高人七级) | 2020-01-09 22:53

@bendanwang: github 上的相关 issue :Can't use Microsoft.AspNetCore.Http (3.0) from a Class Library

dudu | 园豆:38642 (高人七级) | 2020-01-09 22:53

@dudu: 非常感谢,看来只能移到core3.1了

bendanwang | 园豆:152 (初学一级) | 2020-01-09 23:03
其他回答(2)
0

czd890 | 园豆:8412 (大侠五级) | 2020-01-09 17:30

core项目没有问题,standard项目引用不了

支持(0) 反对(0) bendanwang | 园豆:152 (初学一级) | 2020-01-09 18:17
0

遇到同样问题,最后咋解决的

nyth | 园豆:152 (初学一级) | 2020-02-20 12:41
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册