首页新闻找找看学习计划

安装openssl后make python出错

0
悬赏园豆:10 [已解决问题] 解决于 2020-02-20 21:46

系统:deepin15.10
已经存在的Python:3.5.3,2.7
从官网上下载了openssl1.1.1d,./config、make和make install都通过了。
然后配置python3.8.1,configure通过,在make时报错,报错语句./python: /lib/x86_64-linux-gnu/libssl.so.1.1: version `OPENSSL_1_1_1' not found,报错截图如下

./python的依赖关系如下,似乎是少了一个依赖导致出错?

问题补充:

经过我又仔细查看了一变环境变量后,./python的依赖不再显示错误

但make python时依旧报相同的错误

一夕思醉的主页 一夕思醉 | 初学一级 | 园豆:193
提问于:2020-02-20 18:52
< >
分享
最佳答案
0

试试 `OPENSSL_1_1_1' not found (required by openssl) 的方法:

$ export LD_LIBRARY_PATH=/usr/local/lib
收获园豆:10
dudu | 高人七级 |园豆:39411 | 2020-02-20 19:23

这个试过了,得到的结果就是ldd ./python不再有问题,但是make Python依然会报错,并且报错相同

一夕思醉 | 园豆:193 (初学一级) | 2020-02-20 19:29

请问还有什么别的办法吗

一夕思醉 | 园豆:193 (初学一级) | 2020-02-20 19:30

@一夕思醉: 试试

export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu
dudu | 园豆:39411 (高人七级) | 2020-02-20 19:41

@一夕思醉: 如果还是不行,试试

export LD_LIBRARY_PATH=/lib/x86_64-linux-gnu
dudu | 园豆:39411 (高人七级) | 2020-02-20 19:42

@dudu: 多谢,问题已经解决,你提供的github链接很有效

一夕思醉 | 园豆:193 (初学一级) | 2020-02-20 21:46

@一夕思醉: 可以提供一下github链接吗,我也遇到相同问题了

·写虫师 | 园豆:202 (菜鸟二级) | 2020-05-08 09:07
一夕思醉 | 园豆:193 (初学一级) | 2020-05-08 09:15
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册