首页 新闻 搜索 专区 学院

在jexus下部署.NetFramework网站出错

0
[已解决问题] 解决于 2020-03-08 16:54

我的程序使用.Net4.5 , 使用jexus , 部署在linux 本身在Windows下是好的 , 在linux下后报错信息如下 : 

我想知道我现在应该怎么做 , 或者这个是什么问题 数据库连接使用的是ADO.NET

问题背景 : 使用.Net4.5开发的网站要迁移到Linux下, 或者各位大神有没有什么好的方法 , 主要是快, 使用NetCore重新开发一遍是来不及了的.

kaolasz的主页 kaolasz | 初学一级 | 园豆:35
提问于:2020-03-07 12:10
< >
分享
最佳答案
0

问题已经解决 , 参看我另外一个问题的回答 , 另外 @czd890  .NetFrameWork也是可以跨平台的 :)

kaolasz | 初学一级 |园豆:35 | 2020-03-08 16:53

请教一下, nfx如何跨平台,不用mono的情况下

czd890 | 园豆:8999 (大侠五级) | 2020-03-08 22:15

@czd890: 是我的表述出错了 , 不是.netframework跨平台 , 而是mono让它拥有了跨平台的能力 , I'm so sorry . 

kaolasz | 园豆:35 (初学一级) | 2020-03-09 00:24
其他回答(2)
0

去掉数据库连接字符串中的 version 试试

dudu | 园豆:39154 (高人七级) | 2020-03-07 12:31

数据库接字符串中没有写到过version相关属性

支持(0) 反对(0) kaolasz | 园豆:35 (初学一级) | 2020-03-08 01:14
0

4.5不支持部署在linux下。亲。
netfromwork 都不行。除非用mono,建议切换到netcore

czd890 | 园豆:8999 (大侠五级) | 2020-03-07 13:50

jexus专业版自带mono的

支持(0) 反对(0) kaolasz | 园豆:35 (初学一级) | 2020-03-08 00:55
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册