首页 新闻 搜索 专区 学院

后台请求接口输入正确,为什么还会显示用户名不存在?

0
悬赏园豆:20 [已解决问题] 解决于 2020-06-09 15:07

数据库内容截图:

测试接口:

node操作显示

难道是因为数据库密码是密文的???

啾啾啾c的主页 啾啾啾c | 初学一级 | 园豆:91
提问于:2020-03-31 12:59

今天无意重新操作了遍,发现是数据库没导入成功,终于解决了,感谢各位!

啾啾啾c 4个月前
< >
分享
最佳答案
0

DEBUG,SQL打印出来

收获园豆:15
南小鸟 | 初学一级 |园豆:181 | 2020-03-31 16:00
其他回答(3)
0

Login方法贴出来看看

学会乐观 | 园豆:737 (小虾三级) | 2020-03-31 13:09


现在是请求不到一直显示登录失败

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 13:11

@啾啾啾c: 登录验证不应该在后端吗,你把表单提交的数据打印出来看看有没有问题,然后看看数据库是不是同一个,断点调试看看数据在哪一步除了问题,慢慢来

支持(0) 反对(0) 学会乐观 | 园豆:737 (小虾三级) | 2020-03-31 13:23

@学会乐观: 就是用提供好的正确用户名和密码才能实现路由跳转到后台页面,我是新手小白不懂呀o(╥﹏╥)o

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 13:39
0


如果你在前端没有对密码加密, 你这里填写的相当于用户登录时填写的用户名和密码,可能是,添加的密码不对吧

收获园豆:5
wwr01 | 园豆:613 (小虾三级) | 2020-03-31 16:23

密码是123456,我看数据库写的那一串,直接复制了,两个请求都是用户名不存在

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 16:27

@啾啾啾c: 应该是后端的问题吧,你能把代码贴一下吗,或者直接在后端接口处,下断点,看一下你传的参数是否正确

支持(0) 反对(0) wwr01 | 园豆:613 (小虾三级) | 2020-03-31 16:31

@wwr01: 我只有个app.js文件,是那个嘛

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 16:34

@啾啾啾c: 不是,应该看你调用的接口,后端接口也是你写的吗,你能看到吗,如果不能,你就去找写接口的人吧,让他下断点看一下你的参数有没有传过去

支持(0) 反对(0) wwr01 | 园豆:613 (小虾三级) | 2020-03-31 16:41

@wwr01: 不是我写的,我还真没有,这是一个视频教程 ̄□ ̄||

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 16:43

@啾啾啾c: 那你是怎么用postman调用接口的??

支持(0) 反对(0) wwr01 | 园豆:613 (小虾三级) | 2020-03-31 16:50

@wwr01: 就是提供了一个接口文档啊,这个样子的

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 16:52

@啾啾啾c:
你应该把他的程序都下载过来了吧,图中127.0.0.1表示的是本地,你既然能够调用接口,你应该也可以看到接口吧,你使用的是vs吗?

支持(0) 反对(0) wwr01 | 园豆:613 (小虾三级) | 2020-03-31 16:58

@wwr01: 用的vscode,我想了下,你说的是这个嘛

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 17:03

@啾啾啾c:
你可以看一下你调用的js,我没用过vscode,比较尴尬,你看一下引用的js,是哪个,然后打开找到相应的方法

路由应该是这两个拼接的吧

支持(0) 反对(0) wwr01 | 园豆:613 (小虾三级) | 2020-03-31 17:21

@wwr01: login和home分别是对应着Login.vue和Home.vue的

支持(0) 反对(0) 啾啾啾c | 园豆:91 (初学一级) | 2020-03-31 17:24
0

重新装了下sq好了,我只是来结贴的吼吼

啾啾啾c | 园豆:91 (初学一级) | 2020-06-09 15:06
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册