首页 新闻 搜索 专区 学院

Robot Framework框架编辑器打开报错如何解决?求教各位技术大佬?

0
[待解决问题]

Traceback (most recent call last):
File "e:\pyhton\lib\site-packages\robotide\application\application.py", line 58, in OnInit
self.frame = RideFrame(self, self._controller)
File "e:\pyhton\lib\site-packages\robotide\ui\mainframe.py", line 175, in init
self._init_ui()
File "e:\pyhton\lib\site-packages\robotide\ui\mainframe.py", line 279, in _init_ui
self.tree = Tree(self, self.actions,
File "e:\pyhton\lib\site-packages\robotide\ui\tree.py", line 86, in init
self._images = TreeImageList()
File "e:\pyhton\lib\site-packages\robotide\ui\images.py", line 42, in init
TestCaseController: _TreeImage(self, 'robot.png'),
File "e:\pyhton\lib\site-packages\robotide\ui\images.py", line 80, in init
self.normal = self._get_image(image_list, normal)
File "e:\pyhton\lib\site-packages\robotide\ui\images.py", line 91, in _get_image
img = wx.Image(path, wx.BITMAP_TYPE_PNG).ConvertToBitmap()
wx._core.wxAssertionError: C++ assertion "strcmp(setlocale(LC_ALL, NULL), "C") == 0" failed at ....\src\common\intl.cpp(1579) in wxLocale::GetInfo(): You probably called setlocale() directly instead of using wxLocale and now there is a mismatch between C/C++ and Windows locale.
Things are going to break, please only change locale by creating wxLocale objects to avoid this!
OnInit returned false, exiting...
Error in atexit._run_exitfuncs:
wx._core.wxAssertionError: C++ assertion "GetEventHandler() == this" failed at ....\src\common\wincmn.cpp(478) in wxWindowBase::~wxWindowBase(): any pushed event handlers must have been removed
无法打开ride编辑器报错,python3.8+Robot Framework

qlcrmc的主页 qlcrmc | 菜鸟二级 | 园豆:202
提问于:2020-04-15 11:44
< >
分享
所有回答(1)
0

找到"D:\programfile\python3\Lib\site-packages\robotide\application\application.py",第50行 self._initial_locale = wx.Locale(wx.LANGUAGE_ENGLISH) 替换为 self.locale = wx.Locale(wx.LANGUAGE_CHINESE_SIMPLIFIED) 保存后重新启动,启动ok

汪李红 | 园豆:202 (菜鸟二级) | 2021-01-14 16:03

OK!谢谢-

支持(0) 反对(0) qlcrmc | 园豆:202 (菜鸟二级) | 2021-01-15 10:04
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册