首页 新闻 搜索 专区 学院

.net Framework4.7.2 项目下 nuget 引用包报错,包是.net standard 2.0项目

0
悬赏园豆:5 [待解决问题]

项目是.net Framework4.7.2
导入包时用的命令
//https://www.nuget.org/packages/PayPalHttp/

Install-Package PayPalHttp -Version 1.0.0

这个包是用.net standard 2.0的把
但是报了现在图片的的错误,这是什么原因

koi的主页 koi | 初学一级 | 园豆:2
提问于:2020-05-13 23:53
< >
分享
所有回答(4)
0

这个包在.net framework 4.7.2 下 不能用

Tom.汤 | 园豆:2016 (老鸟四级) | 2020-05-14 08:21
0

Nuget 安装呗

猝不及防 | 园豆:1994 (小虾三级) | 2020-05-14 09:16
0

这是我创建的4.7.2下的类库。

默认安装了system.core .net standard 2.0
nuget 上 PayPalHttp 这个包尝试安装了下,确实是需要 .net standard 2.0
你看下你的引用中是否缺少system.core

温暖如太阳 | 园豆:211 (菜鸟二级) | 2020-05-14 09:19
0

对于.net standard 2.0是针对.net core项目的,你的.net freamwork是winform项目,他们之间是不能直接引用的哦,如果必须要引用的话,还是要像楼上那样对core进行引用

水心镜台 | 园豆:247 (菜鸟二级) | 2020-07-30 15:49
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册