首页新闻找找看学习计划

启动项目时报错,求解答

0
悬赏园豆:5 [已解决问题] 解决于 2020-05-31 22:35

react 项目启动时报错了,但是我已经安装了 antd,这是为什么?

zanetti的主页 zanetti | 初学一级 | 园豆:151
提问于:2020-05-30 21:22
< >
分享
最佳答案
0

检查下版本兼容性,可以尝试退回老版本什么的试试。

收获园豆:5
shuai7boy | 菜鸟二级 |园豆:256 | 2020-05-30 21:35

好的,我试试

zanetti | 园豆:151 (初学一级) | 2020-05-30 22:28

我把 antd 的版本退回到 ^3.26.16,启动项目就不报错了,非常感谢!

zanetti | 园豆:151 (初学一级) | 2020-05-31 22:34
其他回答(1)
0

typescript?看看你的tsconfig,感觉像是tsconfig配置的module和target的es配置问题。。。

顾晓北 | 园豆:9892 (大侠五级) | 2020-05-31 09:44

这是 tsconfig 默认的配置,我参考了编译选项,把 target 改为 ESNext 或 ES6,也是报一样的错误。对下面那五个和 module 有关的选项做更改,在 npm start 时会自动变回默认值……

支持(0) 反对(0) zanetti | 园豆:151 (初学一级) | 2020-05-31 22:21
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册