首页 新闻 搜索 专区 学院

maven工程 下了了jar包但是工程引用不了

0
悬赏园豆:5 [待解决问题]

是这样 我在maven工程中加了dom4j 1.6.1版本的依赖,下载也成功了,如图一

但是运行工程时提示找不到dom4j的包,如图二

在project structure中查看jar包发现有个javaDoc冒红不知道是不是这个原因,百度了一下没有找到合适的解决办法,请问有前辈有遇到过这个bug吗。在线等回复

麻烦看看谢谢了

Segho的主页 Segho | 初学一级 | 园豆:156
提问于:2020-07-06 17:23

如果有前辈觉得可能是某些方面的原因也可以大胆告知,我可以试试

Segho 1年前
< >
分享
所有回答(5)
0

刷一下maven可能就好了,maven框框里有个刷新,可以reimport

yytxdy | 园豆:1680 (小虾三级) | 2020-07-06 17:33

谢谢,不过试过了,不行,reimport 或是Download sources 都不行,不知道具体问题在哪里,本地仓库中也是有这个依赖的,就是引用不了

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-06 17:35

@Segho: 删了Repository下的依赖包重新来

支持(0) 反对(0) yytxdy | 园豆:1680 (小虾三级) | 2020-07-06 17:39

@yytxdy: 刚刚试了一下还是有问题,本地仓库重新下的dom4j idea还是提示找不到

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-06 17:45

@yytxdy: 我把repository下所有的依赖包全部清空了,重写引入了一下项目解决了这个问题,你的思路是对的,虽然不知道具体原因是什么,还是成功解决了。

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-08 17:23
0

重启idea清下缓存试试

keeeee | 园豆:202 (菜鸟二级) | 2020-07-06 17:40

嗯这个我也restart过了 清除之后还是同样的问题。

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-06 17:42
0

检查下maven配置,你好像用的idea自带的插件

萧萧弈寒 | 园豆:170 (初学一级) | 2020-07-07 16:37

嗯谢谢提醒 这个我也修改过的 自己下载的maven 检查了很多遍 没有找到问题

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-07 16:39
0

在pom.xml中导入dom4j对应的jar:

<dependency>
    <groupId>dom4j</groupId>
    <artifactId>dom4j</artifactId>
    <version>1.6.1</version>
</dependency>
ycyzharry | 园豆:23855 (高人七级) | 2020-07-07 23:01

谢谢提醒 这个我还是知道的 现在的情况是注入了依赖 也maven刷新并成功下载了 工程饮用不到

支持(0) 反对(0) Segho | 园豆:156 (初学一级) | 2020-07-08 01:34
0

终于找到了解决办法,虽然不知道具体的原因,将maven仓库repository 下的文件夹全部清空,用maven reimport一下,然后将pom文件的依赖更新一下,就可以正常使用,解决明明下载了依赖引用不到jar的情况。

Segho | 园豆:156 (初学一级) | 2020-07-08 17:21
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册