首页 新闻 搜索 专区 学院

EF core 分页低版本问题

0
悬赏园豆:50 [已解决问题] 解决于 2020-10-18 22:59

使用ABP
Incorrect syntax near 'OFFSET'. Invalid usage of the option NEXT in the FETC

用这个没下效果
服务器数据库为 sqlserver 2008R2
.net core 3.2

winds_随风的主页 winds_随风 | 初学一级 | 园豆:140
提问于:2020-10-18 22:21
< >
分享
最佳答案
0

从 .net core 3.0 开始,ef core 不再支持 sql server 2008 的分页,详见 https://github.com/dotnet/efcore/issues/16400

收获园豆:50
dudu | 高人七级 |园豆:37728 | 2020-10-18 22:35

大佬 有什么推荐的高版本sqlserver 版本级别吗

winds_随风 | 园豆:140 (初学一级) | 2020-10-18 22:56

就放服务器 比较稳定的

winds_随风 | 园豆:140 (初学一级) | 2020-10-18 22:57

@winds_随风: 我用的是 SQL Server 2016

dudu | 园豆:37728 (高人七级) | 2020-10-19 07:18

@dudu: 谢谢 dudu 大佬

winds_随风 | 园豆:140 (初学一级) | 2020-10-19 11:04
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册