首页 新闻 搜索 专区 学院

node连接远程oracle报错

0
悬赏园豆:10 [已解决问题] 解决于 2020-12-15 17:43

用的oracledb模块。启动demo时候报错。
错误如下:
Error: DPI-1047: Cannot locate a 64-bit Oracle Client library: "The specified module could not be found". See https://oracle.github.io/node-oracledb/INSTALL.html for help
Node-oracledb installation instructions: https://oracle.github.io/node-oracledb/INSTALL.html
You must have 64-bit Oracle client libraries in your PATH environment variable.
If you do not have Oracle Database on this computer, then install the Instant Client Basic or Basic Light package from
http://www.oracle.com/technetwork/topics/winx64soft-089540.html
A Microsoft Visual Studio Redistributable suitable for your Oracle client library version must be available.

然后我下载了Basic Light包。解压出来是instantclient_19_9文件夹。
里面内容如下:

然后查了几个网上的相关配置,还是连不上报这个错。

啊图啊的主页 啊图啊 | 初学一级 | 园豆:137
提问于:2020-12-03 14:11
< >
分享
最佳答案
0

我也不知道怎么就好了。。。。

啊图啊 | 初学一级 |园豆:137 | 2020-12-15 17:42
其他回答(1)
0

64-bit Oracle Client library
这个提示表明你的oracle instant client库应该不是64位的或者是64位程序看配置路径不对

收获园豆:10
2012 | 园豆:20846 (高人七级) | 2020-12-04 08:44
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册