首页 新闻 搜索 专区 学院

安装qiime2x显示被killed,为啥呢

0
悬赏园豆:10 [已解决问题] 解决于 2021-06-04 16:30

conda env create -n qiime2-2020.11 --file qiime2-2020.11-py36-linux-conda.yml

Collecting package metadata (repodata.json): - Killed

centos7想要安装qiime2,一直装不上,求求大神帮助,谢谢~

凡尘26222的主页 凡尘26222 | 初学一级 | 园豆:2
提问于:2020-12-10 16:28
< >
分享
最佳答案
0

使用下阿里的这个镜像源看看 https://developer.aliyun.com/mirror/centos?spm=a2c6h.13651102.0.0.3e221b11tdP8tM

估计是镜像源出了问题

收获园豆:10
2012 | 高人七级 |园豆:21007 | 2020-12-11 08:03

yum makecache
File "/bin/yum", line 30
except KeyboardInterrupt, e:
^
SyntaxError: invalid syntax

显示语法错误呢,后面该怎么办呢

凡尘26222 | 园豆:2 (初学一级) | 2020-12-11 13:16

凡尘26222 | 园豆:2 (初学一级) | 2020-12-11 13:24

python
Python 3.6.8 (default, Apr 2 2020, 13:34:55)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-39)] on linux
Type "help", "copyright", "credits" or "license" for more information.
我是不是python版本有问题

凡尘26222 | 园豆:2 (初学一级) | 2020-12-11 13:28

@凡尘26222: yum和pyhon3兼容性存在问题,使用python2试试

2012 | 园豆:21007 (高人七级) | 2020-12-12 10:18
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册