首页 新闻 搜索 专区 学院

Microsoft.AspNetCore.Mvc 引用问题

0
悬赏园豆:5 [已解决问题] 解决于 2020-12-17 10:15

我新建了一个asp.net core web  .net5.0的

里面控制器继承的Controller是Microsoft.AspNetCore.Mvc 5.0.0.0的,如下图

---------------

在nuget里面搜索Microsoft.AspNetCore.Mvc,版本是2.2.0,

我在类库里面引用2.2.0的,而web里面是5.0.0.0的会不会多余了

parabeyond008的主页 parabeyond008 | 初学一级 | 园豆:2
提问于:2020-12-17 09:02
< >
分享
最佳答案
0

不影响
最好用一样的

收获园豆:5
不知道风往哪儿吹 | 小虾三级 |园豆:1925 | 2020-12-17 09:14

nuget 里面的 Microsoft.AspNetCore.Mvc 最新的只有 2.2.0 日期是2018年的

parabeyond008 | 园豆:2 (初学一级) | 2020-12-17 09:15

@parabeyond008: 是这样的,.netcore3.0之后,不在发相对应的dll到nuget,改为将这些程序集包含在通过 .NET Core SDK 和运行时安装程序安装的 Microsoft.AspNetCore.App 共享框架中
所以在web种是5.0.nuget引用的是2.2
因为nuget就没有core3.0的dll

不知道风往哪儿吹 | 园豆:1925 (小虾三级) | 2020-12-17 09:55

@不知道风往哪儿吹: 

最好用一样的

是web 和 类库都用Microsoft.AspNetCore.Mvc 2.2 版本吗

parabeyond008 | 园豆:2 (初学一级) | 2020-12-17 09:59

@parabeyond008:


框架里面其实已经有引用了,直接用就行了,不需要在从nuget里面添加引用

不知道风往哪儿吹 | 园豆:1925 (小虾三级) | 2020-12-17 10:05
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册