首页 新闻 搜索 专区 学院

Cefsharp适合.NET Core项目吗?

0
悬赏园豆:10 [待解决问题]

.NET Core Winform项目的,Nuget也是安装Cefsharp.Winforms和Cefsharp.Commen吗?

刚提示Cefsharp.Winforms程序集无法加载,不知道是项目环境不合适还是依赖项缺失。

PER10的主页 PER10 | 初学一级 | 园豆:84
提问于:2020-12-27 21:14
< >
分享
所有回答(4)
0
E行者 | 园豆:1664 (小虾三级) | 2020-12-28 08:38

这个是用在.net framework项目的例子
地址里的CefSharp.MinimalExample.WinForms/app.config有提到

支持(0) 反对(0) PER10 | 园豆:84 (初学一级) | 2020-12-28 20:09
0

几个月前通讯还需要依赖framework,还在观望。

花飘水流兮 | 园豆:12303 (专家六级) | 2020-12-28 09:50

我觉得好像不行,github上的Cefsharp.core似乎都没完成,零散几个文件

支持(0) 反对(0) PER10 | 园豆:84 (初学一级) | 2020-12-28 20:07

@PER10: 你需要看它的说明文件需要改项目文件。

.net core 3是可以的,不过用着没有framework靠谱。主要是netcore 都需要特么的下载组件依赖,那么用户跟用framework没求区别,这个比较恶心。空了再看看,那个win7的问题怎么打包处理。

支持(0) 反对(0) 花飘水流兮 | 园豆:12303 (专家六级) | 2021-01-11 12:22
0

哈哈哈哈,终于有人掉坑里了,太难了,我磕磕绊绊搞定了,但是!现在又不用了,我全删了

小草上飞飞 | 园豆:211 (菜鸟二级) | 2020-12-28 17:27

我当初用的是 75.1.143.0,新版本的搞不明白,太难了

支持(0) 反对(0) 小草上飞飞 | 园豆:211 (菜鸟二级) | 2020-12-28 17:28

你用在.NET Core项目还是.NET Framework?

支持(0) 反对(0) PER10 | 园豆:84 (初学一级) | 2020-12-28 20:06

@PER10: NET Framework

支持(0) 反对(0) 小草上飞飞 | 园豆:211 (菜鸟二级) | 2020-12-29 08:02

@小草上飞飞: 嗯哼

支持(0) 反对(0) PER10 | 园豆:84 (初学一级) | 2020-12-29 12:12
0

你要不试试WebView2,基于chromium内核的edge,支持net4.7,core,C++,支持集成已安装的软件或者独占的内置软件包,支持Windows,Linux和arm64。微软原生控件。感觉第三方chrome控件在微软亲自下场以后没生存空间了,毕竟人力物力都不可能抗衡微软,维护肯定不如原生控件。

coredx | 园豆:624 (小虾三级) | 2021-01-07 18:24

这个是挺好的,我上次试过了,但WebView2对应的Edge版本还是属于开发版,也就是说目前使用WebView2大部分用户可能用不了。估计要等用户得到Windows Update更新把浏览器更新成支持WebView2才行吧。反正我会继续观望这个。

支持(0) 反对(0) PER10 | 园豆:84 (初学一级) | 2021-01-08 02:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册