首页 新闻 搜索 专区 学院

刚升级了.net5 写了个ef的测试,怎么就不行了?

0
[待解决问题]


最简单的一个weiapi的例子,就加了一个ef启动就挂了,求大神帮忙看看

wangqy的主页 wangqy | 菜鸟二级 | 园豆:202
提问于:2021-01-11 17:13
< >
分享
所有回答(2)
0

依赖注入的问题?看看startup.cs

lastmemory | 园豆:506 (小虾三级) | 2021-01-12 08:41

大神快帮我看看吧

支持(0) 反对(0) wangqy | 园豆:202 (菜鸟二级) | 2021-01-12 08:42

@wangqy: 看不出来🏳

支持(0) 反对(0) lastmemory | 园豆:506 (小虾三级) | 2021-01-12 08:51

@slowstart: 是的啊,我也是很纳闷,完全看不出来有问题

支持(0) 反对(0) wangqy | 园豆:202 (菜鸟二级) | 2021-01-12 08:52

@slowstart: 同样代码在.netcore 3.1没有问题的,升级到.net5就这样了

支持(0) 反对(0) wangqy | 园豆:202 (菜鸟二级) | 2021-01-12 08:55

@wangqy: 两个csproj里面ef版本一样的吧

支持(0) 反对(0) lastmemory | 园豆:506 (小虾三级) | 2021-01-12 09:02

@slowstart: 不一样的,.net5 项目里的ef,我也升级到最新了

支持(0) 反对(0) wangqy | 园豆:202 (菜鸟二级) | 2021-01-12 09:02
0

没注入服务。知道依赖注入吗?

不知道风往哪儿吹 | 园豆:1925 (小虾三级) | 2021-01-12 09:30
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册