首页 新闻 搜索 专区 学院

升级 k8s 遭遇 CoreDNS 配置迁移问题

0
悬赏园豆:50 [已解决问题] 解决于 2021-01-14 09:04

在将 kubernetes 从 1.17.0 升级至 1.18.0,运行 kubeadm upgrade plan 后出现下面的错误提示:

[preflight] Some fatal errors occurred:
	[ERROR CoreDNSUnsupportedPlugins]: CoreDNS cannot migrate the following plugins:
[Option "answer" in plugin "rewrite" is unsupported by this migration tool in 1.6.5. Option "answer" in plugin "rewrite" is unsupported by this migration tool in 1.6.5.]

请问如何解决?

k8s
dudu的主页 dudu | 高人七级 | 园豆:38273
提问于:2021-01-13 22:47
< >
分享
最佳答案
0

可以通过 ignore-preflight-errors 参数忽略错误

kubeadm upgrade plan --ignore-preflight-errors=CoreDNSUnsupportedPlugins
dudu | 高人七级 |园豆:38273 | 2021-01-14 09:04
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册