首页 新闻 搜索 专区 学院

关于CVE-2021-3156:Sudo 堆缓冲区溢出漏洞_poc

0
悬赏园豆:5 [待解决问题]

问:是因为我sudo的版本不对吗?操作系统是redhat7
按照步骤实现poc如下:
在github下载的poc包,使用普通用户dyr登录

提示这个错误之后
将for(int i=0)改为了
int i;
for(i=0)
make执行;运行脚本之后弹出这个内容

dyr用户的id依然是1000,非0
我的sudo版本:

yilv阳光的主页 yilv阳光 | 菜鸟二级 | 园豆:201
提问于:2021-02-01 16:03
< >
分享
所有回答(1)
0

list targets:

$ ./sudo-hax-me-a-sandwich
run:

$ ./sudo-hax-me-a-sandwich <target_number> ---- 这里写上你列举出来的系统版本代号 即,0 1 2

vagaa | 园豆:202 (菜鸟二级) | 2021-02-09 10:27
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册