首页 新闻 搜索 专区 学院

依赖在windows上运行的war包有没有什么版本可以让他在linux上也运行

0
悬赏园豆:20 [待解决问题]

公司有个软件,之前一直在windows上运行,公司改革需要在linux上运行,所有的服务都迁移过去了,但只有其中一个war包,测试人员说是只能在windows上运行,
有没有大佬,比如:能在linux上增加依赖或者什么的,能让这个包在linux上运行,求了

何以清欢渡的主页 何以清欢渡 | 初学一级 | 园豆:0
提问于:2021-02-25 17:06

111111

何以清欢渡 2个月前
< >
分享
所有回答(6)
0

整个tomcat、把war包往里一扔。就完事了

Ctrl` | 园豆:3246 (老鸟四级) | 2021-02-25 17:07

不啊,如果这样,那这个war包在windows上肯定也扔在tomcat下,但他是单独运行的一个war包

支持(0) 反对(0) 何以清欢渡 | 园豆:0 (初学一级) | 2021-02-25 17:42
0

依赖了windows的啥东西?

yytxdy | 园豆:1680 (小虾三级) | 2021-02-25 17:11

vc2010和vc2015

支持(0) 反对(0) 何以清欢渡 | 园豆:0 (初学一级) | 2021-02-25 17:52
0

你先把这个包在linux下面跑起来, 看能不能起来, 如果不能则有什么错误, 然后我们在讨论是不是有可能.

czd890 | 园豆:11893 (专家六级) | 2021-02-25 17:47
0

逻辑上来说要改代码吧

ycyzharry | 园豆:23926 (高人七级) | 2021-03-06 23:56
0

第三方war包 如果是系统级别的 依赖只能找对应系统版本依赖替换了吧
java程序的话 一样应该都会有不同系统的实现吧

蓝羽code | 园豆:295 (菜鸟二级) | 2021-03-12 15:24
0

这玩意跟本没法整

何以清欢渡 | 园豆:0 (初学一级) | 2021-08-09 14:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册