首页 新闻 搜索 专区 学院

Ubuntu配置阿里镜像源,更新后提示错误?

1
悬赏园豆:5 [已解决问题] 解决于 2021-09-17 13:37

Ubuntu16.04

如下步骤配置阿里镜像源

sudo mv /etc/apt/sources.list /etc/apt/sources.list.bak
sudo vim /etc/apt/sources.list	
  • 添加阿里镜像源
deb http://mirrors.aliyun.com/ubuntu/ bionic main restricted universe multiverse
# deb-src https://mirrors.aliyun.com/ubuntu/ bionic main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ bionic-updates main restricted universe multiverse
# deb-src http://mirrors.aliyun.com/ubuntu/ bionic-updates main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://mirrors.aliyun.com/ubuntu/ bionic-backports main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ bionic-security main restricted universe multiverse
# deb-src http://mirrors.aliyun.com/ubuntu/ bionic-security main restricted universe multiverse
  • 执行更新,提示错误,但是没看懂
sudo apt-get update

  • 执行升级,也有错误
sudo apt-get upgrade

问题1:错误提示是什么意思,有什么影响?
问题2:如何处理这种错误提示?

小黑狗cathy的主页 小黑狗cathy | 初学一级 | 园豆:84
提问于:2021-09-17 09:47
< >
分享
最佳答案
0
收获园豆:5
快乐的凡人721 | 小虾三级 |园豆:1379 | 2021-09-17 09:49

我用了链接里的16.04重新配了镜像源,更新后还是出现提示。有一个情况是机器是不通外网的,这个会跟提示有关吗?

小黑狗cathy | 园豆:84 (初学一级) | 2021-09-17 10:07

@小黑狗cathy:
你都说了是 【不通外网】了,
外网的服务器能访问吗?不能的。

这样的话,
需要什么软件,就去 下载压缩包,然后U盘拷贝到你的Ubuntu里面 安装、测试 吧,

不对,U盘也不行,不安全。
拷贝到某台 主机上,再使用 命令把文件 拷贝到 你的Ubuntu。

快乐的凡人721 | 园豆:1379 (小虾三级) | 2021-09-17 10:20
其他回答(1)
0

阿里云源有内网地址的。阿里云的机器都能用。
阿里云的服务器默认就是使用阿里云内的源。
你试试改成mirrors.cloud.aliyuncs.com能不能用.

墨镜带佬星 | 园豆:2121 (老鸟四级) | 2021-09-17 11:30

多谢了,老铁

支持(0) 反对(0) 小黑狗cathy | 园豆:84 (初学一级) | 2021-09-17 13:35
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册