首页 新闻 搜索 专区 学院

Ubuntu 使用ccmake 时,提示cmake版本不够,但是我cmake已经升级了

0
悬赏园豆:10 [已解决问题] 解决于 2021-09-26 15:39
                                                                   
Press [enter] to edit option Press [d] to delete an entry   CMake Version 3.10.2
Press [c] to configure
Press [h] for help           Press [q] to quit without generating
Press [t] to toggle advanced mode (Currently Off)
 CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
   CMake 3.12.0 or higher is required.  You are running version 3.10.2
~/dev/cpp/QGIS/build-master$ cmake --version
cmake version 3.21.3

CMake suite maintained and supported by Kitware (kitware.com/cmake).

echo_lovely的主页 echo_lovely | 菜鸟二级 | 园豆:372
提问于:2021-09-25 20:53
< >
分享
最佳答案
0

不知道CMake是啥,
但看你的 Error 是 多版本造成的吧?
运行的脚本或程序里面的环境变量中,是否用的旧版本的CMake?

注意第一行的:
Press [d] to delete an entry CMake Version 3.10.2
删除!

收获园豆:10
快乐的凡人721 | 小虾三级 |园豆:1372 | 2021-09-25 21:10

确实,我已经找到解决方法了,把软连接删除,生成一个3.21.3的就好了

echo_lovely | 园豆:372 (菜鸟二级) | 2021-09-26 15:38
其他回答(2)
0
  • 根据提示信息看,系统在识别 Cmake 的时候是找到了 3.10.2 版本
  • 安装 QGIS 需要 3.12.0 版本
  • 你确实安装了 cmake 更高的 3.21.3 版本
  • 那问题就出在 系统怎么在 安装 QGIS 识别到错误的版本 上了
  • 分析一下QGIS的安装脚本,或者楼上说的,移除 3.10.2版本
去哪里吃鱼 | 园豆:251 (菜鸟二级) | 2021-09-26 14:51
0
rm cmake

ln -s cmake 3.21.3
echo_lovely | 园豆:372 (菜鸟二级) | 2021-09-26 15:39

即 删掉 /usr/local 里原来的,再创建一个新的

支持(0) 反对(0) echo_lovely | 园豆:372 (菜鸟二级) | 2021-09-26 15:40

@echo_lovely:
很棒!你这才是最优答案!

支持(0) 反对(0) 快乐的凡人721 | 园豆:1372 (小虾三级) | 2021-09-26 19:06

@快乐的凡人721: 那确实,但是自己不能给自己最佳

支持(0) 反对(0) echo_lovely | 园豆:372 (菜鸟二级) | 2021-09-26 21:25
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册