首页 新闻 搜索 专区 学院

ubuntu 16.04 升级 18.04 时报错"Invalid package information"

0
悬赏园豆:30 [已解决问题] 解决于 2021-12-27 21:14

用 do-release-upgrade 命令准备将 ubuntu 16.04 服务器升级至 18.04,在升级过程中出现下面的错误:

After updating your package information, the essential package 'ubuntu-minimal' could not be located. This may be because you have no official mirrors listed in your software sources, or because of excessive load on the mirror you are using. See /etc/apt/sources.list for the current list of configured software sources. In the case of an overloaded mirror, you may want to try the upgrade again later.

请问如何解决?

dudu的主页 dudu | 高人七级 | 园豆:36310
提问于:2021-12-27 20:11
< >
分享
最佳答案
0

是 /etc/apt/sources.list 中的镜像源设置引起的,后来清空 sources.list 改为下面的阿里云镜像源解决了

deb http://mirrors.aliyun.com/ubuntu/ xenial main multiverse restricted universe
deb http://mirrors.aliyun.com/ubuntu/ xenial-backports main multiverse restricted universe
deb http://mirrors.aliyun.com/ubuntu/ xenial-proposed main multiverse restricted universe
deb http://mirrors.aliyun.com/ubuntu/ xenial-security main multiverse restricted universe
deb http://mirrors.aliyun.com/ubuntu/ xenial-updates main multiverse restricted universe
deb-src http://mirrors.aliyun.com/ubuntu/ xenial main multiverse restricted universe
deb-src http://mirrors.aliyun.com/ubuntu/ xenial-backports main multiverse restricted universe
deb-src http://mirrors.aliyun.com/ubuntu/ xenial-proposed main multiverse restricted universe
deb-src http://mirrors.aliyun.com/ubuntu/ xenial-security main multiverse restricted universe
deb-src http://mirrors.aliyun.com/ubuntu/ xenial-updates main multiverse restricted universe
dudu | 高人七级 |园豆:36310 | 2021-12-27 21:14
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册