首页 新闻 搜索 专区 学院

python安装第三方库时遇到的问题

0
[待解决问题]

各位敲python的大佬,我在这里见笑了,我想为我的pythonIDE加上几个第三方库,按照网上的教程在CMD输入”pip install numpy“,可以下载,但是,好像系统不能为这个库造轮子”failed build wheel for numpy“,网上找不到教程,希望有大佬能帮我一把!

远方有风吹来的主页 远方有风吹来 | 菜鸟二级 | 园豆:202
提问于:2022-05-08 21:49
< >
分享
所有回答(5)
-1

用.net就没这么麻烦了!!!

anarki2 | 园豆:202 (菜鸟二级) | 2022-05-08 22:59

谢谢

支持(0) 反对(0) 远方有风吹来 | 园豆:202 (菜鸟二级) | 2022-05-15 16:05
0

可以在https://www.lfd.uci.edu/~gohlke/pythonlibs/
下载whl文件进行安装就好了

墨镜带佬星 | 园豆:2255 (老鸟四级) | 2022-05-08 23:58

谢谢

支持(0) 反对(0) 远方有风吹来 | 园豆:202 (菜鸟二级) | 2022-05-15 16:05

@远方有风吹来: 标记为解决就行,不用额外回复.

支持(0) 反对(0) 墨镜带佬星 | 园豆:2255 (老鸟四级) | 2022-05-16 19:14
0

python2吗?

echo_lovely | 园豆:662 (小虾三级) | 2022-05-09 08:41

python3,现在已经解决了

支持(0) 反对(0) 远方有风吹来 | 园豆:202 (菜鸟二级) | 2022-05-15 16:05
0

numpy 依赖很多(你要明确自己的系统位数、Python版本、安装的 numpy 版本)

  1. 按网上的教程安装,别人会附带遇到的问题及解决方案(教程不可能找不到 https://blog.csdn.net/weixin_42216236/article/details/120639540)
  2. 找对应的 *.whl 安装包
〆灬丶 | 园豆:891 (小虾三级) | 2022-05-09 11:29

谢谢指导,最后我直接下载annaconda上面的spyder。

支持(1) 反对(0) 远方有风吹来 | 园豆:202 (菜鸟二级) | 2022-05-15 16:05
0

pycharm 自动识别然后点击安装 不好吗

不苦 | 园豆:68 (初学一级) | 2022-06-01 00:44
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册