首页 新闻 搜索 专区 学院

node-sass sass-loader vue空项目都安不上这俩

0
[已解决问题] 解决于 2022-07-07 09:53
E:\Code\Vue\flight-vue>npm install node-sass sass-loader --save-dev
npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: flight-vue@1.0.0
npm ERR! Found: webpack@3.12.0
npm ERR! node_modules/webpack
npm ERR!   dev webpack@"^3.6.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer webpack@"^5.0.0" from sass-loader@13.0.2
npm ERR! node_modules/sass-loader
npm ERR!   dev sass-loader@"*" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See E:\nodejs-repository\cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     E:\nodejs-repository\cache\_logs\2022-07-06T08_19_27_001Z-debug-0.log

看样子是版本冲突导致的,但是我这个项目是空项目,通过下面命令安装的

vue init webpack flight-vue
vue
echo_lovely的主页 echo_lovely | 小虾三级 | 园豆:791
提问于:2022-07-06 16:40
< >
分享
最佳答案
0

用vite构建项目,就不会有这两个包问题,安装sass的时候就只用执行 npm install sass (不再去安装那两个包)
而且vite编译起来更快,谁用谁知道。
PS:这两个包问题已经劝退很多人了.....(非常难用)

奖励园豆:5
默卿 | 大侠五级 |园豆:6295 | 2022-07-06 17:25

我刚开始学vue,还不知道怎么用呢,我就对着慕课的视频构建的项目,他这么整的
然后我看vue3用的是vite,2也能用吗?

echo_lovely | 园豆:791 (小虾三级) | 2022-07-06 17:32

@echo_lovely: 可以,但是没有那么丝滑。

默卿 | 园豆:6295 (大侠五级) | 2022-07-06 17:37

@默卿: 我沉默了

echo_lovely | 园豆:791 (小虾三级) | 2022-07-06 17:38

@echo_lovely: https://blog.csdn.net/weixin_35773751/article/details/124418960 你也可以参考这里,修改node的版本,和包的版本,往回退一些,或者使用dart-sass来替换node-sass

默卿 | 园豆:6295 (大侠五级) | 2022-07-06 17:50

@默卿: 应该是我创建项目的姿势不对,我用的是

vue init webpack 【project name】

好像换成

vue create 【project name】

就没问题了。而且换了之后默认就是dart-sass

echo_lovely | 园豆:791 (小虾三级) | 2022-07-07 09:52
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册