首页 新闻 搜索 专区 学院

已装.net C#编译时还提示要安装,求解决办法,谢谢!

0
悬赏园豆:50 [已解决问题] 解决于 2022-10-19 16:47

提示信息:to run this application,you must install .net. would you like to download it now?

已安装的.net最高版本为:v4.0.30319

App.config 加了 <?xml version="1.0" encoding="utf-8" ?> 但没效果

求解决办法,谢谢!

tea2007的主页 tea2007 | 初学一级 | 园豆:4
提问于:2022-10-15 17:20
< >
分享
最佳答案
0

v4.0.30319 一般是指IIS的.NET CLR版本,一般不是我们说的SDK版本,你应该去安装对应的.net core sdk或者.net framework ,一般使用vs 开发,安装vs 就会自带安装一些常见版本;

收获园豆:35
diudiu1 | 小虾三级 |园豆:881 | 2022-10-15 18:01
其他回答(4)
0

.csproj 文件中 TargetFrameworkVersion 是多少?

收获园豆:5
dudu | 园豆:35024 (高人七级) | 2022-10-15 17:55
0

你这啥也没有,不好排查问题

收获园豆:5
MrNice | 园豆:3248 (老鸟四级) | 2022-10-16 15:17
0

多数人安装.net sdk的时候会不喜欢安装了.net clr。如果下载比较麻烦 ,可以直接在vs的安装程序里面,选择指定的版本来安装,目前vistual studio 2017以上都支持。

收获园豆:5
ensleep | 园豆:1682 (小虾三级) | 2022-10-17 08:35
0

自己解决了,是源码编写用的是.net5.0 .本机装个.net5.0以上就没事了。

tea2007 | 园豆:4 (初学一级) | 2022-10-19 16:45
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册