首页新闻找找看学习计划

vs2010 ajax3.5 问题

0
悬赏园豆:100 [已关闭问题] 关闭于 2010-06-13 17:47

在VS2010安装了

AjaxControlToolkit.Binary.NET4 新建.NET framework4.0网站

代码
<asp:ScriptManager ID="ScriptManager1" runat="server">
</asp:ScriptManager>

<asp:Panel ID="Panel1" runat="server" Height="192px" Width="200px">
<asp:Panel ID="Panel2" runat="server" Height="33px" Width="196px"
BackColor
="#999999">
</asp:Panel>
</asp:Panel>
<asp:DragPanelExtender ID="DragPanelExtender1" runat="server" TargetControlID="Panel1" DragHandleID="Panel2">
</asp:DragPanelExtender>

 

实现拖动没问题

但是安装了AjaxControlToolkit.Binary.NET35  新建.NET framework3.5网站

同样的代码却无法实现拖动效果了 请各位高手指点一下,为何会这样?

kinglex的主页 kinglex | 初学一级 | 园豆:0
提问于:2010-06-11 19:53
< >
分享
所有回答(3)
0

孩子 还是安装回VS2008吧 现在很多企业或项目还没用到4.0框架 所有有些东西难免也就不兼容

youngkeen | 园豆:8 (初学一级) | 2010-06-11 21:12
0

装了.net4版本的AjaxControlToolkit就不要再回去再装.net3.5版本了吧?何况安装顺序好像不对。

3.5的部署是一件非常麻烦的事,framearok 3.5有100多M,核心还是framewrok2

framearok 4只有40多M,核心是framewrok4

如果用.net4,就索性放弃以前的版本

邀月 | 园豆:25327 (高人七级) | 2010-06-12 07:41
0

代码是没有问题,运行环境的问题,有可能是你装的太多了,可以随便到一个服务器上试试。

不建议使用这些控件包,生成的代码太多,要效果还是用JQUERY或自己的写,相对比较灵活。

Astar | 园豆:40805 (高人七级) | 2010-06-12 09:01
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册