首页 新闻 搜索 专区 学院

WCF RIA Services部署 必须是服务器必须支持.net4么

0
悬赏园豆:100 [已关闭问题]

 WCF RIA Services部署 必须是服务器必须支持.net4和IIS7么?  国内的空间商目前都支持asp.net3.5版本 该怎么办?

On the  Way的主页 On the Way | 初学一级 | 园豆:10
提问于:2010-06-14 17:26
< >
分享
其他回答(2)
0

WCF RIA Service 必须要 Silverlight 4 的支持。

eaglet | 园豆:17139 (专家六级) | 2010-06-16 08:09
0

 得是4.0。http://social.microsoft.com/Forums/zh-CN/silverlightzhchs/thread/5b5b1640-842c-4a15-8153-565e1e7c00d

国内很多空间已经支持4.0了,西部数码就支持了,你可以给空间商提建议。或者自己购买VPS,自己装就可以了,现在买空间和VPS的价格差不了多少。

Astar | 园豆:40805 (高人七级) | 2010-06-17 10:06
0

WCF RIA Services是基于WCF的,WCF并非需要.NET4,但是非IIS7.x部署WCF需要额外配置。

使用 WCF RIA Services多数是为了直接给Silverlight使用,那么这就看sl的版本了,如果是sl4.0就需要.NET4,是sl3.0就需要.NET3.5sp1

如果容易找到ASP.NET3.5的空间,那你可以使用WCF代替 WCF RIA Services,然后在Silverlight项目里添加服务引用就行了

冒冒 | 园豆:210 (菜鸟二级) | 2010-06-18 23:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册