首页 新闻 搜索 专区 学院

一个关于IIS的问题

0
悬赏园豆:5 [待解决问题]

我用的IIS5.0,之前发布了一个.NET网站,测试可以通过IIS来浏览,最近再次浏览网站时,报错,无法显示该页!浏览.HTML页没有问题,ASPX文件的就不行,请大家帮帮忙啊,非常感谢!

yixin841210的主页 yixin841210 | 小虾三级 | 园豆:1138
提问于:2010-08-16 11:18
< >
分享
所有回答(5)
0

检查你的IIS中 WEB服务扩展列表里,CGI ASP ASP.net ISAPI 是否都启用了.同时记下 asp.net 启用的版本号,

然后再到你的网站的 asp.net 标签zho能够察看版本号是否一致.

最后再从你的网站的主目录的应用程序配置中查看aspx文件是否在应用程序扩展中.

Launcher | 园豆:45045 (高人七级) | 2010-08-16 11:23
IIS5里我没找到WEB服务扩展列表啊,IIS6里有,我现在用的是IIS5
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-16 11:55
IIS5的不跟IIS管理器在一起,不太好找,我这里也没有IIS5,也不好帮你找.
支持(0) 反对(0) Launcher | 园豆:45045 (高人七级) | 2010-08-16 12:52
0

建议升级到6.0,或者7.0,问题就不会这么多了,而且各方面的性能也更优,

  应该是没有ISAPI 没有启用吧

jowo | 园豆:2834 (老鸟四级) | 2010-08-16 11:28
XP可以装6.0吗,我装过很多次都不行啊,我是SP3的
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-16 11:52
0

重装IIS,重新安装相应版本的.net framework。

Astar | 园豆:40805 (高人七级) | 2010-08-16 11:49
0

重新安装下aspnet_regiis.exe,看看是不是ASP.NET文件损坏了。

kyo-yo | 园豆:5587 (大侠五级) | 2010-08-16 12:22
重运行aspnet_regiis.exe -i,也不行,我想直接装IIS6,xp sp3能装的了吗?
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-16 13:08
不是那么容易安装上去的,有文章介绍如何安装,我试过,但是没成功过.
支持(0) 反对(0) Launcher | 园豆:45045 (高人七级) | 2010-08-16 14:39
@Galactica:XP上转IIS6很烦,还不如装WIN直接就有IIS7了。正好升级系统了
支持(0) 反对(0) kyo-yo | 园豆:5587 (大侠五级) | 2010-08-16 15:22
0

重装iis,然后重新注册.net framework对应的版本试试

myurl | 园豆:225 (菜鸟二级) | 2011-12-15 23:12
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册