首页 新闻 搜索 专区 学院

.NET部署的问题

0
悬赏园豆:5 [待解决问题]

我.NET网站在部署完访问的时候,报错了,说是:

未找到编译器可执行文件 csc.exe

大家帮忙看看吧

yixin841210的主页 yixin841210 | 小虾三级 | 园豆:1138
提问于:2010-08-17 09:22
< >
分享
所有回答(7)
0

看看在C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727(或者3.5版本:v3.5)目录下能找到csc.exe

kyo-yo | 园豆:5587 (大侠五级) | 2010-08-17 09:26
可以找到啊
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-17 09:27
0

看下这个目 C:\WINDOWS\Microsoft.NET\Framework\,在相应的版本下面看看有没有 csc.exe 文件, 没有的话, 去别的电脑上面拷贝个对应的版本过来试试。

HUHU慈悲 | 园豆:9973 (大侠五级) | 2010-08-17 09:29
那就有可能 网站发布的时候出问题了,看看,是否选择的所有必须的文件了。
支持(0) 反对(0) HUHU慈悲 | 园豆:9973 (大侠五级) | 2010-08-17 09:31
@佛本慈悲: csc.exe文件时可以找到的
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-17 10:47
0
你的C#编译器csc.exe丢了。
可能是最近安装、卸载什么软件把VS损坏了。
还是重装VS吧。在添加删除程序里面,找到vs2008,点更改删除。
选择维护模式。等吧。
jowo | 园豆:2834 (老鸟四级) | 2010-08-17 09:49
重装还是出现这个问题,在VS下都不能打开网页
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-17 10:48
下载.NET FRAMEWORK 3.5安装包,覆盖安装一次
支持(0) 反对(0) jowo | 园豆:2834 (老鸟四级) | 2010-08-17 15:02
0

注册表坏了,重新安装吧!

要不把你的网站编译后再发布吧!

Launcher | 园豆:45045 (高人七级) | 2010-08-17 09:52
0
Astar | 园豆:40805 (高人七级) | 2010-08-17 09:52
恩,谢谢,都改过了,还是不行啊
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-17 10:49
@yixin841210:重新安装.netframework。
支持(0) 反对(0) Astar | 园豆:40805 (高人七级) | 2010-08-17 10:55
0

一、如果是web Application,尽量封装在cs文件或相应的类库dll中,而不需要运行时再编译。

二、如果是webSite,建议转换为web Application

邀月 | 园豆:25375 (高人七级) | 2010-08-17 10:49
0

重新安装一下.net framework

慧☆星 | 园豆:5555 (大侠五级) | 2010-08-29 18:00
恩,谢谢,已经行了,重装了一下系统,呵呵
支持(0) 反对(0) yixin841210 | 园豆:1138 (小虾三级) | 2010-08-30 08:41
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册